0
Validation results

Woffice

Woffice

WordPress 4.8.2 theme
0
Critical alerts
  1. Security breaches : Use of base64_decode() Found base64_decode in file apiUtils.php.
    Line 37: return base64_decode($b64);
    Found base64_decode in file OAuth.php.
    Line 126: $decoded_sig = base64_decode($signature);
  2. Security breaches : Use of base64_encode() Found base64_encode in file apiUtils.php.
     $b64 = base64_encode($data);
    Found base64_encode in file apiMediaFileUpload.php.
     $related .= '\r\n' . base64_encode($data) . '\r\n';
    Found base64_encode in file OAuth.php.
     return base64_encode( hash_hmac('sha1', $base_string, $key, true));
     return base64_encode($signature);
  3. Presence of iframes : iframes are sometimes used to load unwanted adverts and malicious code on another site Found <iframe src="https://www.wunderlist.com/lists/<?php echo $project_wunderlist; ?> in file single-project.php.
    Line 255: <iframe src='https://www.wunderlist.com/lists/<?php echo $project_wunderlis
  4. Malware : Operations on file system file_get_contents was found in the file class-fw-extension-woffice-map.php
    Line 70: $request = file_get_contents('https://maps.google.com/maps/api/geocode/json?address=' 
    Line 109: $request = file_get_contents('https://maps.google.com/maps/api/geocode/json?address=' 
    file_get_contents was found in the file class-fw-extension-woffice-map.php
    Line 70: $request = file_get_contents('https://maps.google.com/maps/api/geocode/json?address=' 
    Line 109: $request = file_get_contents('https://maps.google.com/maps/api/geocode/json?address=' 
    fopen was found in the file hooks.php
    Line 125: $output = fopen('php://output', 'w');
    fclose was found in the file hooks.php
    Line 137: fclose($output);
    file_get_contents was found in the file apiP12Signer.php
    Line 36: $p12 = file_get_contents($p12file);
    fopen was found in the file OAuth.php
    Line 110: $fp = fopen($GLOBALS['PRIV_KEY_FILE'], 'r');
    fread was found in the file OAuth.php
    Line 111: $privKey = fread($fp, 8192);
    fclose was found in the file OAuth.php
    Line 112: fclose($fp);
    file_get_contents was found in the file apiFileCache.php
    Line 97: if (($data = @file_get_contents($storageFile)) !== false) {
    file_put_contents was found in the file apiFileCache.php
    Line 122: if (! @file_put_contents($storageFile, $data)) {
    fopen was found in the file hooks.php
    Line 444: $fp = fopen(get_template_directory().'/js/manifest.json', 'w');
    fwrite was found in the file hooks.php
    Line 445: fwrite($fp, $json_content);
    fclose was found in the file hooks.php
    Line 446: fclose($fp);
  5. Malware : Network operations curl_init was found in the file apiCurlIO.php
    Line 93: $ch = curl_init();
    curl_exec was found in the file apiCurlIO.php
    Line 111: $respData = curl_exec($ch);
    Line 118: $respData = curl_exec($ch);
    curl_exec was found in the file apiCurlIO.php
    Line 111: $respData = curl_exec($ch);
    Line 118: $respData = curl_exec($ch);
  6. Hidden admin bar : Hidden admin Bar Themes should not hide admin bar. Detected in file : hooks.php.
  7. Deprecated functions : get_currentuserinfo get_currentuserinfo found in file single-wiki.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 84: get_currentuserinfo();
    get_currentuserinfo found in file helpers.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 61: get_currentuserinfo();
    get_currentuserinfo found in file single.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 99: get_currentuserinfo();
    get_currentuserinfo found in file multiverso.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 52: get_currentuserinfo();
  8. Registration of theme features : Implementation of add_theme_support() add_theme_support() was found in the file hooks.php. However get_post_format and/or has_post_format were not found, and no use of formats in the CSS was detected.
  9. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was multiverso.zip eventon-full-cal.zip eventon.zip ._eventon-full-cal.zip ._multiverso.zip ._eventon.zip.
Warning
  1. special URIs : Presence of bad theme tagsTheme URI and Author URI should not be the same.
  2. theme tags : Presence of bad theme tagsThe tag green has been deprecated, it must be removed from style.css header.The tag gray has been deprecated, it must be removed from style.css header.The tag white has been deprecated, it must be removed from style.css header.The tag dark has been deprecated, it must be removed from style.css header.The tag light has been deprecated, it must be removed from style.css header.The tag responsive-layout has been deprecated, it must be removed from style.css header.Themes that use the tag accessibility-ready will need to undergo an accessibility review.
    See https://make.wordpress.org/themes/handbook/review/accessibility/
  3. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function __, with the arguments 'woocommerce' in file cart-totals.php.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are woffice, framework, bbpress, it-l10n-ithemes-exchange, personalize-login, buddypress, woocommerce, tgmpa.
  4. Plugin territory : Plugin territory functionalitiesThe theme uses the register_post_type() function, which is plugin-territory functionality.The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
  5. Custom elements : Presence of custom headerNo reference to custom header was found in the theme.
  6. Custom elements : Presence of custom backgroundNo reference to custom background was found in the theme.
  7. Featured image : Use of the_post_thumbnail() instead of custom fields for thumbnailsNo reference to the_post_thumbnail was found in the theme.
  8. Screenshot : Screenshot fileScreenshot size is 880x660px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Static links : Presence of hard-coded linksPossible hard-coded links were found in the file options.php.
    Line 36: 'html' => __('If you need more options about this, please use the default shortcode generator from the plugin, it is slower but you\'ll find more options. You can also have  a look on this article for more details', 'woffice'). '<a href='https://2f.ticksy.com/article/5099/' target='_blank'>https://2f.ticksy.com/
    Possible hard-coded links were found in the file settings-options.php.
    Line 18: 'desc'  => __('We are using the GeoCoding Google API to get coordinates from users locations. By default it is working with our API key but as there are many Woffice around, the Quota (2500 requests per day) may be reached really quickly so the map will no longer be available. That is why it is important to use you own Google API key. Please see : ', 'woffice'). '<a href='https://2f.ticksy.com/article/4227/'>Tutorial</a>',
    Possible hard-coded links were found in the file settings-options.php.
    Line 19: 'html'  => 'Please make sure you have read the <a href='https://2f.ticksy.com/article/4261' target='_blank'>tutorial about Google L
    Line 64: 'html'  => 'Please make sure you have read the <a href='https://2f.ticksy.com/article/4456/' target='_blank'>tutorial about Faceboo
    Possible hard-coded links were found in the file apiWebfontsService.php.
    Line 66: * <a href='http://code.google.com/apis/webfonts/docs/developer_api.html' target='_blan
    Possible hard-coded links were found in the file apiLatitudeService.php.
    Line 171: * <a href='http://code.google.com/apis/latitude/v1/using_rest.html' target='_blank'>AP
    Possible hard-coded links were found in the file apiCustomsearchService.php.
    Line 77: * <a href='http://code.google.com/apis/customsearch/v1/using_rest.html' target='_blank
    Possible hard-coded links were found in the file apiModeratorService.php.
    Line 876: * <a href='http://code.google.com/apis/moderator/v1/using_rest.html' target='_blank'>A
    Possible hard-coded links were found in the file apiFreebaseService.php.
    Line 131: * <a href='http://wiki.freebase.com/wiki/New_Freebase_API' target='_blank'>API Documen
    Possible hard-coded links were found in the file apiTasksService.php.
    Line 307: * <a href='http://code.google.com/apis/tasks/v1/using.html' target='_blank'>API Docume
    Possible hard-coded links were found in the file apiAdsenseService.php.
    Line 653: * <a href='https://code.google.com/apis/adsense/management/' target='_blank'>API Docum
    Possible hard-coded links were found in the file apiShoppingService.php.
    Line 148: * <a href='http://code.google.com/apis/shopping/search/v1/getting_started.html' target
    Possible hard-coded links were found in the file apiPagespeedonlineService.php.
    Line 69: * <a href='https://code.google.com/apis/pagespeedonline/v1/getting_started.html' targe
    Possible hard-coded links were found in the file apiSiteVerificationService.php.
    Line 161: * <a href='http://code.google.com/apis/siteverification/' target='_blank'>API Document
    Possible hard-coded links were found in the file apiOrkutService.php.
    Line 856: * <a href='http://code.google.com/apis/orkut/v2/reference.html' target='_blank'>API Do
    Possible hard-coded links were found in the file apiAnalyticsService.php.
    Line 264: * <a href='http://code.google.com/apis/analytics' target='_blank'>API Documentation</a
    Possible hard-coded links were found in the file apiGanService.php.
    Line 237: * <a href='https://code.google.com/apis/gan/' target='_blank'>API Documentation</a>
    Possible hard-coded links were found in the file apiPredictionService.php.
    Line 154: * <a href='http://code.google.com/apis/predict/docs/developer-guide.html' target='_bla
    Possible hard-coded links were found in the file apiTranslateService.php.
    Line 129: * <a href='http://code.google.com/apis/language/translate/v2/using_rest.html' target='
    Possible hard-coded links were found in the file apiBloggerService.php.
    Line 277: * <a href='https://code.google.com/apis/blogger/docs/2.0/json/getting_started.html' ta
    Possible hard-coded links were found in the file apiCalendarService.php.
    Line 705: * <a href='http://code.google.com/apis/calendar/v3/using.html' target='_blank'>API Doc
    Possible hard-coded links were found in the file apiPlusService.php.
    Line 227: * <a href='http://developers.google.com/+/api/' target='_blank'>API Documentation</a>
    Possible hard-coded links were found in the file apiBigqueryService.php.
    Line 478: * <a href='https://code.google.com/apis/bigquery/docs/v2/' target='_blank'>API Documen
    Possible hard-coded links were found in the file apiUrlshortenerService.php.
    Line 101: * <a href='http://code.google.com/apis/urlshortener/v1/getting_started.html' target='_
    Possible hard-coded links were found in the file apiBooksService.php.
    Line 539: * <a href='https://code.google.com/apis/books/docs/v1/getting_started.html' target='_b
    Possible hard-coded links were found in the file login.php.
    Line 263: 'desc' => __('Do you want to see a Recaptcha2 checkbox on the register page, if you select 'yep' please fill the fields below. Very first thing you need to do is register your website on Google recaptcha to do that click :','woffice'). '<a href='https://www.google.com/recaptcha/'>https://www.google.com/recaptcha/</a>',
    Possible hard-coded links were found in the file change-avatar.php.
    Line 7: <p><?php _e( 'Your profile photo will be used on your profile and throughout the site. If there is a <a href='http://gravatar.com'>Gravatar</a> associated with your account email we wil
    Line 55: <p><?php _e( 'Your profile photo will be used on your profile and throughout the site. To change your profile photo, please create an account with <a href='http://gravatar.com'>Gravatar</a> using the same email address as you used 
    Line 7: <p><?php _e( 'Your profile photo will be used on your profile and throughout the site. If there is a <a href='http://gravatar.com'>Gravatar</a> associated with your account email we wil
    Line 55: <p><?php _e( 'Your profile photo will be used on your profile and throughout the site. To change your profile photo, please create an account with <a href='http://gravatar.com'>Gravatar</a> using the same email address as you used 
    Possible hard-coded links were found in the file frontend.php.
    Line 466: <small><?php _e( 'You can use : ', 'woffice' ); ?><a href='http://www.latlong.net/' target='_blank'>LatLong.net</a></small>
    Line 473: <small><?php _e( 'You can use : ', 'woffice' ); ?><a href='http://www.latlong.net/' target='_blank'>LatLong.net</a></small>
    Line 466: <small><?php _e( 'You can use : ', 'woffice' ); ?><a href='http://www.latlong.net/' target='_blank'>LatLong.net</a></small>
    Line 473: <small><?php _e( 'You can use : ', 'woffice' ); ?><a href='http://www.latlong.net/' target='_blank'>LatLong.net</a></small>
    Line 490: <small><?php _e( 'Please see : ', 'woffice' ); ?><a href='http://fortawesome.github.io/Font-Awesome/icons/' target='_blank'>FontAweso
  2. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  3. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  4. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  5. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  6. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  7. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  8. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  9. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : hooks.php
    Line 172: require_once(WP_PLUGIN_DIR . '/multiverso/inc/functions.php');
    Line 174: require_once(get_template_directory() . '/inc/multiverso.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-fw-extension-woffice-poll.php
    Line 73: require_once( ABSPATH . 'wp-admin/includes/upgrade.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiWebfontsService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiLatitudeService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiOauth2Service.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiCustomsearchService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiModeratorService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiFreebaseService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiTasksService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiAdsenseService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiShoppingService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    Line 47: * @opt_param string facets.include Facets to include (applies when useGcsConfig == false)
    Line 167: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiPagespeedonlineService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiSiteVerificationService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiOrkutService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiAnalyticsService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiGanService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiPredictionService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiTranslateService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiBloggerService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiCalendarService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiPlusService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiUrlshortenerService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiBooksService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiSigner.php
    Line 18: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiAuth.php
    Line 18: 
    Line 19: 
    Line 20: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiVerifier.php
    Line 18: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiOAuth.php
    Line 18: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiOAuth2.php
    Line 18: 
    Line 19: 
    Line 20: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiService.php
    Line 18: require_once 'service/apiServiceResource.php';
    Line 19: require_once 'service/apiServiceRequest.php';
    Line 20: require_once 'service/apiBatch.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : config.php
    Line 19: require_once('../wp-load.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiIO.php
    Line 18: require_once 'io/apiHttpRequest.php';
    Line 19: require_once 'io/apiCurlIO.php';
    Line 20: require_once 'io/apiREST.php';
    Line 21: require_once 'io/apiRPC.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiREST.php
    Line 18: 
    Line 19: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiCurlIO.php
    Line 25: require_once 'apiCacheParser.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiClient.php
    Line 39: 
    Line 43: require_once ($cwd . '/local_config.php');
    Line 48: require_once 'service/apiModel.php';
    Line 49: require_once 'service/apiService.php';
    Line 50: require_once 'service/apiServiceRequest.php';
    Line 51: require_once 'auth/apiAuth.php';
    Line 52: require_once 'cache/apiCache.php';
    Line 53: require_once 'io/apiIO.php';
    Line 54: require_once('service/apiMediaFileUpload.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiCache.php
    Line 18: 
    Line 19: 
    Line 20: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : googleplusoauth.php
    Line 15: require_once('../wp-load.php');
    Line 17: require_once 'googleplusoauth/apiClient.php';
    Line 18: require_once 'googleplusoauth/contrib/apiPlusService.php';
    Line 37: require_once('../wp-load.php');
    Line 39: require_once 'googleplusoauth/apiClient.php';
    Line 40: require_once 'googleplusoauth/contrib/apiPlusService.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : hooks.php
    Line 173: require_once(ABSPATH . 'wp-admin/includes/file.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-tgm-plugin-activation.php
    Line 1061: require_once( ABSPATH . 'wp-admin/includes/class-wp-list-table.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : frontend.php
    Line 267: require_once(ABSPATH . 'wp-admin' . '/includes/image.php');
    Line 268: require_once(ABSPATH . 'wp-admin' . '/includes/file.php');
    Line 269: require_once(ABSPATH . 'wp-admin' . '/includes/media.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-widget-wpml.php
    Line 26: include( $filepath );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-widget-cf7.php
    Line 26: include( $filepath );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-widget-eventon.php
    Line 27: include( $filepath );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-widget-visualizer.php
    Line 26: include( $filepath );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : hooks.php
    Line 106: require_once(get_template_directory() . '/inc/customize.php');
    Line 113: require_once(get_template_directory() . '/inc/autocomplete.php');
    Line 397: require_once(get_template_directory() . '/inc/register.php');
    Line 416: require_once(get_template_directory() . '/inc/frontend.php');
    Line 509: require_once(get_template_directory() . '/inc/buddypress.php');
    Line 1537: return include(get_template_directory() . '/inc/allfiles.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.

This is a ThemeForest theme. Since Themeforest items are all checked by a human before they appear on their website, ThemeForest verification rules are more permissive than themecheck's and can give a better verification score ( Themeforest requirements ).

0
Critical alerts
  1. Malware : Network operations curl_init was found in the file apiCurlIO.php
    Line 93: $ch = curl_init();
    curl_exec was found in the file apiCurlIO.php
    Line 111: $respData = curl_exec($ch);
    Line 118: $respData = curl_exec($ch);
    curl_exec was found in the file apiCurlIO.php
    Line 111: $respData = curl_exec($ch);
    Line 118: $respData = curl_exec($ch);
  2. Hidden admin bar : Hidden admin Bar Themes should not hide admin bar. Detected in file : hooks.php.
  3. Deprecated functions : get_currentuserinfo get_currentuserinfo found in file single-wiki.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 84: get_currentuserinfo();
    get_currentuserinfo found in file helpers.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 61: get_currentuserinfo();
    get_currentuserinfo found in file single.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 99: get_currentuserinfo();
    get_currentuserinfo found in file multiverso.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 52: get_currentuserinfo();
  4. Registration of theme features : Implementation of add_theme_support() add_theme_support() was found in the file hooks.php. However get_post_format and/or has_post_format were not found, and no use of formats in the CSS was detected.
  5. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was multiverso.zip eventon-full-cal.zip eventon.zip ._eventon-full-cal.zip ._multiverso.zip ._eventon.zip.
Warning
  1. special URIs : Presence of bad theme tagsTheme URI and Author URI should not be the same.
  2. theme tags : Presence of bad theme tagsThe tag green has been deprecated, it must be removed from style.css header.The tag gray has been deprecated, it must be removed from style.css header.The tag white has been deprecated, it must be removed from style.css header.The tag dark has been deprecated, it must be removed from style.css header.The tag light has been deprecated, it must be removed from style.css header.The tag responsive-layout has been deprecated, it must be removed from style.css header.Themes that use the tag accessibility-ready will need to undergo an accessibility review.
    See https://make.wordpress.org/themes/handbook/review/accessibility/
  3. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function __, with the arguments 'woocommerce' in file cart-totals.php.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are woffice, framework, bbpress, it-l10n-ithemes-exchange, personalize-login, buddypress, woocommerce, tgmpa.
  4. Plugin territory : Plugin territory functionalitiesThe theme uses the register_post_type() function, which is plugin-territory functionality.The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
  5. Featured image : Use of the_post_thumbnail() instead of custom fields for thumbnailsNo reference to the_post_thumbnail was found in the theme.
  6. Screenshot : Screenshot fileScreenshot size is 880x660px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Static links : Presence of hard-coded linksPossible hard-coded links were found in the file options.php.
    Line 36: 'html' => __('If you need more options about this, please use the default shortcode generator from the plugin, it is slower but you\'ll find more options. You can also have  a look on this article for more details', 'woffice'). '<a href='https://2f.ticksy.com/article/5099/' target='_blank'>https://2f.ticksy.com/
    Possible hard-coded links were found in the file settings-options.php.
    Line 18: 'desc'  => __('We are using the GeoCoding Google API to get coordinates from users locations. By default it is working with our API key but as there are many Woffice around, the Quota (2500 requests per day) may be reached really quickly so the map will no longer be available. That is why it is important to use you own Google API key. Please see : ', 'woffice'). '<a href='https://2f.ticksy.com/article/4227/'>Tutorial</a>',
    Possible hard-coded links were found in the file settings-options.php.
    Line 19: 'html'  => 'Please make sure you have read the <a href='https://2f.ticksy.com/article/4261' target='_blank'>tutorial about Google L
    Line 64: 'html'  => 'Please make sure you have read the <a href='https://2f.ticksy.com/article/4456/' target='_blank'>tutorial about Faceboo
    Possible hard-coded links were found in the file apiWebfontsService.php.
    Line 66: * <a href='http://code.google.com/apis/webfonts/docs/developer_api.html' target='_blan
    Possible hard-coded links were found in the file apiLatitudeService.php.
    Line 171: * <a href='http://code.google.com/apis/latitude/v1/using_rest.html' target='_blank'>AP
    Possible hard-coded links were found in the file apiCustomsearchService.php.
    Line 77: * <a href='http://code.google.com/apis/customsearch/v1/using_rest.html' target='_blank
    Possible hard-coded links were found in the file apiModeratorService.php.
    Line 876: * <a href='http://code.google.com/apis/moderator/v1/using_rest.html' target='_blank'>A
    Possible hard-coded links were found in the file apiFreebaseService.php.
    Line 131: * <a href='http://wiki.freebase.com/wiki/New_Freebase_API' target='_blank'>API Documen
    Possible hard-coded links were found in the file apiTasksService.php.
    Line 307: * <a href='http://code.google.com/apis/tasks/v1/using.html' target='_blank'>API Docume
    Possible hard-coded links were found in the file apiAdsenseService.php.
    Line 653: * <a href='https://code.google.com/apis/adsense/management/' target='_blank'>API Docum
    Possible hard-coded links were found in the file apiShoppingService.php.
    Line 148: * <a href='http://code.google.com/apis/shopping/search/v1/getting_started.html' target
    Possible hard-coded links were found in the file apiPagespeedonlineService.php.
    Line 69: * <a href='https://code.google.com/apis/pagespeedonline/v1/getting_started.html' targe
    Possible hard-coded links were found in the file apiSiteVerificationService.php.
    Line 161: * <a href='http://code.google.com/apis/siteverification/' target='_blank'>API Document
    Possible hard-coded links were found in the file apiOrkutService.php.
    Line 856: * <a href='http://code.google.com/apis/orkut/v2/reference.html' target='_blank'>API Do
    Possible hard-coded links were found in the file apiAnalyticsService.php.
    Line 264: * <a href='http://code.google.com/apis/analytics' target='_blank'>API Documentation</a
    Possible hard-coded links were found in the file apiGanService.php.
    Line 237: * <a href='https://code.google.com/apis/gan/' target='_blank'>API Documentation</a>
    Possible hard-coded links were found in the file apiPredictionService.php.
    Line 154: * <a href='http://code.google.com/apis/predict/docs/developer-guide.html' target='_bla
    Possible hard-coded links were found in the file apiTranslateService.php.
    Line 129: * <a href='http://code.google.com/apis/language/translate/v2/using_rest.html' target='
    Possible hard-coded links were found in the file apiBloggerService.php.
    Line 277: * <a href='https://code.google.com/apis/blogger/docs/2.0/json/getting_started.html' ta
    Possible hard-coded links were found in the file apiCalendarService.php.
    Line 705: * <a href='http://code.google.com/apis/calendar/v3/using.html' target='_blank'>API Doc
    Possible hard-coded links were found in the file apiPlusService.php.
    Line 227: * <a href='http://developers.google.com/+/api/' target='_blank'>API Documentation</a>
    Possible hard-coded links were found in the file apiBigqueryService.php.
    Line 478: * <a href='https://code.google.com/apis/bigquery/docs/v2/' target='_blank'>API Documen
    Possible hard-coded links were found in the file apiUrlshortenerService.php.
    Line 101: * <a href='http://code.google.com/apis/urlshortener/v1/getting_started.html' target='_
    Possible hard-coded links were found in the file apiBooksService.php.
    Line 539: * <a href='https://code.google.com/apis/books/docs/v1/getting_started.html' target='_b
    Possible hard-coded links were found in the file login.php.
    Line 263: 'desc' => __('Do you want to see a Recaptcha2 checkbox on the register page, if you select 'yep' please fill the fields below. Very first thing you need to do is register your website on Google recaptcha to do that click :','woffice'). '<a href='https://www.google.com/recaptcha/'>https://www.google.com/recaptcha/</a>',
    Possible hard-coded links were found in the file change-avatar.php.
    Line 7: <p><?php _e( 'Your profile photo will be used on your profile and throughout the site. If there is a <a href='http://gravatar.com'>Gravatar</a> associated with your account email we wil
    Line 55: <p><?php _e( 'Your profile photo will be used on your profile and throughout the site. To change your profile photo, please create an account with <a href='http://gravatar.com'>Gravatar</a> using the same email address as you used 
    Line 7: <p><?php _e( 'Your profile photo will be used on your profile and throughout the site. If there is a <a href='http://gravatar.com'>Gravatar</a> associated with your account email we wil
    Line 55: <p><?php _e( 'Your profile photo will be used on your profile and throughout the site. To change your profile photo, please create an account with <a href='http://gravatar.com'>Gravatar</a> using the same email address as you used 
    Possible hard-coded links were found in the file frontend.php.
    Line 466: <small><?php _e( 'You can use : ', 'woffice' ); ?><a href='http://www.latlong.net/' target='_blank'>LatLong.net</a></small>
    Line 473: <small><?php _e( 'You can use : ', 'woffice' ); ?><a href='http://www.latlong.net/' target='_blank'>LatLong.net</a></small>
    Line 466: <small><?php _e( 'You can use : ', 'woffice' ); ?><a href='http://www.latlong.net/' target='_blank'>LatLong.net</a></small>
    Line 473: <small><?php _e( 'You can use : ', 'woffice' ); ?><a href='http://www.latlong.net/' target='_blank'>LatLong.net</a></small>
    Line 490: <small><?php _e( 'Please see : ', 'woffice' ); ?><a href='http://fortawesome.github.io/Font-Awesome/icons/' target='_blank'>FontAweso
  2. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  3. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  4. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  5. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  6. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  7. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  8. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  9. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : hooks.php
    Line 172: require_once(WP_PLUGIN_DIR . '/multiverso/inc/functions.php');
    Line 174: require_once(get_template_directory() . '/inc/multiverso.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-fw-extension-woffice-poll.php
    Line 73: require_once( ABSPATH . 'wp-admin/includes/upgrade.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiWebfontsService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiLatitudeService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiOauth2Service.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiCustomsearchService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiModeratorService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiFreebaseService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiTasksService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiAdsenseService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiShoppingService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    Line 47: * @opt_param string facets.include Facets to include (applies when useGcsConfig == false)
    Line 167: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiPagespeedonlineService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiSiteVerificationService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiOrkutService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiAnalyticsService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiGanService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiPredictionService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiTranslateService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiBloggerService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiCalendarService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiPlusService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiUrlshortenerService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiBooksService.php
    Line 18: require_once 'service/apiModel.php';
    Line 19: require_once 'service/apiService.php';
    Line 20: require_once 'service/apiServiceRequest.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiSigner.php
    Line 18: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiAuth.php
    Line 18: 
    Line 19: 
    Line 20: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiVerifier.php
    Line 18: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiOAuth.php
    Line 18: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiOAuth2.php
    Line 18: 
    Line 19: 
    Line 20: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiService.php
    Line 18: require_once 'service/apiServiceResource.php';
    Line 19: require_once 'service/apiServiceRequest.php';
    Line 20: require_once 'service/apiBatch.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : config.php
    Line 19: require_once('../wp-load.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiIO.php
    Line 18: require_once 'io/apiHttpRequest.php';
    Line 19: require_once 'io/apiCurlIO.php';
    Line 20: require_once 'io/apiREST.php';
    Line 21: require_once 'io/apiRPC.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiREST.php
    Line 18: 
    Line 19: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiCurlIO.php
    Line 25: require_once 'apiCacheParser.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiClient.php
    Line 39: 
    Line 43: require_once ($cwd . '/local_config.php');
    Line 48: require_once 'service/apiModel.php';
    Line 49: require_once 'service/apiService.php';
    Line 50: require_once 'service/apiServiceRequest.php';
    Line 51: require_once 'auth/apiAuth.php';
    Line 52: require_once 'cache/apiCache.php';
    Line 53: require_once 'io/apiIO.php';
    Line 54: require_once('service/apiMediaFileUpload.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : apiCache.php
    Line 18: 
    Line 19: 
    Line 20: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : googleplusoauth.php
    Line 15: require_once('../wp-load.php');
    Line 17: require_once 'googleplusoauth/apiClient.php';
    Line 18: require_once 'googleplusoauth/contrib/apiPlusService.php';
    Line 37: require_once('../wp-load.php');
    Line 39: require_once 'googleplusoauth/apiClient.php';
    Line 40: require_once 'googleplusoauth/contrib/apiPlusService.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : hooks.php
    Line 173: require_once(ABSPATH . 'wp-admin/includes/file.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-tgm-plugin-activation.php
    Line 1061: require_once( ABSPATH . 'wp-admin/includes/class-wp-list-table.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : frontend.php
    Line 267: require_once(ABSPATH . 'wp-admin' . '/includes/image.php');
    Line 268: require_once(ABSPATH . 'wp-admin' . '/includes/file.php');
    Line 269: require_once(ABSPATH . 'wp-admin' . '/includes/media.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-widget-wpml.php
    Line 26: include( $filepath );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-widget-cf7.php
    Line 26: include( $filepath );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-widget-eventon.php
    Line 27: include( $filepath );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-widget-visualizer.php
    Line 26: include( $filepath );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : hooks.php
    Line 106: require_once(get_template_directory() . '/inc/customize.php');
    Line 113: require_once(get_template_directory() . '/inc/autocomplete.php');
    Line 397: require_once(get_template_directory() . '/inc/register.php');
    Line 416: require_once(get_template_directory() . '/inc/frontend.php');
    Line 509: require_once(get_template_directory() . '/inc/buddypress.php');
    Line 1537: return include(get_template_directory() . '/inc/allfiles.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes