99
Validation results

Weaver Xtreme

Free WordPress 4.9.5 theme

Weaver Xtreme

Free WordPress 4.9.5 theme
99
  • THEME TYPEWordPress theme 4.9.5
  • FILE NAMEweaver-xtreme.3.2.3.zip
  • FILE SIZE1679296 bytes
  • MD5422767e66143ca05f2ae27d8dc49eee1
  • SHA15c0414fe4f6ae56f9a7da9fabd6641c920be9500
  • LICENSEGNU GPL 3
  • FILES INCLUDEDCSS, PHP, HTML, Bitmap images
  • VERSION3.2.3
  • TAGSone-column, two-columns, three-columns, left-sidebar, right-sidebar, custom-background, custom-colors, custom-header, custom-logo, custom-menu, editor-style, featured-image-header, featured-images, flexible-header, footer-widgets, full-width-template, microformats, post-formats, rtl-language-support, sticky-post, theme-options, threaded-comments, translation-ready
  • CREATION DATE2018-03-22
  • LAST FILE UPDATE2018-04-12
  • LAST VALIDATION2018-04-12 17:11
  • OTHER VERSIONS

    3.1.7 : 60%

    3.1.4 : 60%

    3.1.3 : 60%

    3.1.12 : 100%

    3.1 : 40%

    2.1.3 : 59%

    2.1.2 : 59%

    2.0.9 : 58%

    2.0.8 : 38%

    1.3 : 78%

Error 8 : Undefined variable: cms
In /home/www/themecheck/themecheck/controllers/controller_results.php line 818
Warning
  1. theme tags : Presence of bad theme tagsFound wrong tag custom-logo in style.css header.
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  5. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  6. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  7. Use of includes : Use of include or requireThe theme appears to use include or require : download.php
    Line 7: require_once($wp_root . 'wp-load.php');
    Line 9: require_once($wp_root . 'wp-config.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : lib-runtime.php
    Line 175: require_once(get_template_directory() . '/includes/generatecss.php');
    Line 189: require_once(get_template_directory() . '/includes/generatecss.php');
    Line 1384: require_once( get_template_directory() . '/includes/fileio.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : wphead.php
    Line 31: require_once(get_template_directory() . '/includes/generatecss.php'); 	// i
    Line 57: require_once(get_template_directory() . '/includes/generatecss.php'); 	// i
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : trt-customize-pro-top.php
    Line 67: //require_once( trailingslashit( get_template_directory() ) . 'trt-customize-
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : load-customizer.php
    Line 42: require_once( $path . 'alpha-color-picker/alpha-color-picker.php' );
    Line 43: require_once( $path . 'save-restore/save-restore.php' );
    Line 44: require_once( $path . 'lib-controls.php' );
    Line 405: require_once( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : save-restore.php
    Line 245: require_once( ABSPATH . 'wp-admin/includes/file.php' );
    Line 406: require_once(get_template_directory() . '/includes/generatecss.php');
    Line 635: require_once(get_template_directory() . '/includes/generatecss.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : addon-plugins.php
    Line 7: require_once( get_template_directory() . WEAVERX_ADMIN_DIR . '/class-tgm-pl
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : admin-top.php
    Line 264: require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/admin-plus.php' 
    Line 265: require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/admin-help.php' 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : load-admin-core.php
    Line 38: require_once(get_template_directory() . WEAVERX_ADMIN_DIR . '/admin-top.php
    Line 78: require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/lib-admin.php' )
    Line 96: require_once(get_template_directory() . WEAVERX_ADMIN_DIR . '/admin-page-po
    Line 100: require_once(get_template_directory() . WEAVERX_ADMIN_DIR . '/addon-plugins
    Line 110: require_once(get_template_directory() . '/admin/customizer/load-customizer.
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes