38
Validation results

Weaver Xtreme

Free WordPress 4.9.8 theme

Weaver Xtreme

Free WordPress 4.9.8 theme
38
    Error 8 : Undefined index: slug
    In /home/www/themecheck/themecheck/controllers/controller_results.php line 772
  • THEME TYPEWordPress theme 4.9.8
  • FILE NAMEweaver-xtreme.2.0.8.zip
  • FILE SIZE1717419 bytes
  • MD539b41bcacb90423ccb55497f5435c62f
  • SHA178f96bbe92cd073521ad9df9a87eb46ca01985ac
  • LICENSEGNU GPL 3
  • FILES INCLUDEDCSS, PHP, HTML, Bitmap images
  • VERSION2.0.8
  • TAGSlight, dark, white, black, gray, one-column, two-columns, three-columns, left-sidebar, right-sidebar, fluid-layout, responsive-layout, custom-background, custom-colors, custom-header, custom-menu, editor-style, featured-image-header, featured-images, flexible-header, full-width-template, post-formats, rtl-language-support, sticky-post, theme-options, threaded-comments, photoblogging
  • CREATION DATE2017-06-06
  • LAST FILE UPDATE2017-06-06
  • LAST VALIDATION2017-06-06 14:04
  • OTHER VERSIONS

    4.0.3 : 99%

    3.2.3 : 99%

    3.1.7 : 60%

    3.1.4 : 60%

    3.1.3 : 60%

    3.1.12 : 100%

    3.1 : 40%

    2.1.3 : 59%

    2.1.2 : 59%

    2.0.9 : 58%

    1.3 : 78%

Error 8 : Undefined variable: cms
In /home/www/themecheck/themecheck/controllers/controller_results.php line 818
Critical alerts
  1. Customizer : Sanitization of Customizer settings Found a Customizer setting that did not have a sanitization callback function in file load-customizer.php. Every call to the add_setting() method needs to have a sanitization callback function passed.
  2. Unwanted files : hidden file(s) or folder(s) .komodotools was found.
  3. Admin menu : Themes should use add_theme_page() for adding admin pages. File class-tgm-plugin-activation.php :
    Line 648: // $this->page_hook = call_user_func( 'add_{$type}_page', $args['parent_slug'], $args['page_title'], $args['menu_t
Warning
  1. theme tags : Presence of bad theme tagsThe tag light has been deprecated, it must be removed from style.css header.The tag dark has been deprecated, it must be removed from style.css header.The tag white has been deprecated, it must be removed from style.css header.The tag black has been deprecated, it must be removed from style.css header.The tag gray has been deprecated, it must be removed from style.css header.The tag fluid-layout has been deprecated, it must be removed from style.css header.The tag responsive-layout has been deprecated, it must be removed from style.css header.The tag photoblogging has been deprecated, it must be removed from style.css header.
  2. Screenshot : Screenshot fileScreenshot size is 300x225px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  5. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  6. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  7. Use of includes : Use of include or requireThe theme appears to use include or require : download.php
    Line 7: require_once($wp_root . 'wp-load.php');
    Line 9: require_once($wp_root . 'wp-config.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : lib-runtime.php
    Line 149: require_once(get_template_directory() . '/includes/generatecss.php');
    Line 163: require_once(get_template_directory() . '/includes/generatecss.php');
    Line 1201: require_once( get_template_directory() . '/includes/fileio.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : wphead.php
    Line 27: require_once(get_template_directory() . '/includes/generatecss.php'); 	// i
    Line 58: require_once(get_template_directory() . '/includes/generatecss.php'); 	// i
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : load-customizer.php
    Line 35: require_once( dirname( __FILE__ ) . '/alpha-color-picker/alpha-color-picker
    Line 36: require_once( dirname( __FILE__ ) . '/save-restore/save-restore.php' );
    Line 37: require_once( dirname( __FILE__ ) . '/lib-controls.php' );
    Line 394: require_once( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : save-restore.php
    Line 241: require_once( ABSPATH . 'wp-admin/includes/file.php' );
    Line 402: require_once(get_template_directory() . '/includes/generatecss.php');
    Line 629: require_once(get_template_directory() . '/includes/generatecss.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : addon-plugins.php
    Line 7: require_once( get_template_directory() . WEAVERX_ADMIN_DIR . '/class-tgm-pl
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : admin-top.php
    Line 316: //require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/lib-admin.php' )
    Line 317: //++++++++ require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/lib-admin-part2.
    Line 319: //++++++ require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/admin-subthemes.
    Line 320: //++++++ require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/admin-mainopts.p
    Line 321: //++++++ require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/admin-advancedop
    Line 322: require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/admin-plus.php' 
    Line 323: require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/admin-help.php' 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : load-admin-core.php
    Line 38: require_once(get_template_directory() . WEAVERX_ADMIN_DIR . '/admin-top.php
    Line 75: require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/lib-admin.php' )
    Line 76: //require_once( get_template_directory().WEAVERX_ADMIN_DIR.'/lib-admin-part2.
    Line 94: require_once(get_template_directory() . WEAVERX_ADMIN_DIR . '/admin-page-po
    Line 98: require_once(get_template_directory() . WEAVERX_ADMIN_DIR . '/addon-plugins
    Line 107: require_once(get_template_directory() . '/admin/customizer/load-customizer.
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes