0
Validation results

Strata

Strata

WordPress 4.9.2 theme
0
Critical alerts
  1. Title : Title No reference to add_theme_support( "title-tag" ) was found in the theme.The theme needs to have <title> tags, ideally in the header.php file.The theme needs to have a call to wp_title(), ideally in the header.php file.
  2. Security breaches : Use of base64_decode() Found base64_decode in file qode-import.php.
    Line 133: $unserialized_content = unserialize(base64_decode($file_content));
  3. Security breaches : Use of base64_encode() Found base64_encode in file recaptchalib.php.
     return strtr(base64_encode ($x), '+/', '-_');
  4. Presence of iframes : iframes are sometimes used to load unwanted adverts and malicious code on another site Found <iframe src="http://www.youtube.com/embed/<?php echo get_post_meta(get_the_ID(), "video_format_link", true); ?> in file blog_large_image_whole_post-loop.php.
    Line 24: <iframe  src='http://www.youtube.com/embed/<?php echo get_post_meta(get_the
    Found <iframe width="100%" src="https://www.youtube.com/embed/<?php echo $portfolio_image['portfoliovideoid']; ?> in file single-portfolio_page.php.
    Line 138: <iframe width='100%' src='https://www.youtube.com/embed/<?php echo $portfol
    Found <iframe src="http://www.youtube.com/embed/<?php echo get_post_meta(get_the_ID(), "video_format_link", true); ?> in file blog_small_image-loop.php.
    Line 24: <iframe  src='http://www.youtube.com/embed/<?php echo get_post_meta(get_the
    Found <iframe src="'. $server . '/noscript?k=' . $pubkey . $errorpart . '" height="300" width="500" frameborder="0"> in file recaptchalib.php.
    Line 126: <iframe src=''. $server . '/noscript?k=' . $pubkey . $errorpart . '' height
    Found <iframe src="http://www.youtube.com/embed/<?php echo get_post_meta(get_the_ID(), "video_format_link", true); ?> in file blog_single-loop.php.
    Line 28: <iframe src='http://www.youtube.com/embed/<?php echo get_post_meta(get_the_
    Found <iframe src="http://www.youtube.com/embed/<?php echo get_post_meta(get_the_ID(), "video_format_link", true); ?> in file blog_masonry-loop.php.
    Line 23: <iframe src='http://www.youtube.com/embed/<?php echo get_post_meta(get_the_
    Found <iframe src="http://www.youtube.com/embed/<?php echo get_post_meta(get_the_ID(), "video_format_link", true); ?> in file blog_large_image-loop.php.
    Line 24: <iframe  src='http://www.youtube.com/embed/<?php echo get_post_meta(get_the
  5. Malware : Operations on file system fwrite was found in the file recaptchalib.php
    Line 85: fwrite($fs, $http_request);
    fclose was found in the file recaptchalib.php
    Line 89: fclose($fs);
    file_get_contents was found in the file parsers.php
    Line 66: $success = $dom->loadXML( file_get_contents( $file ) );
    Line 269: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {
    file_get_contents was found in the file parsers.php
    Line 66: $success = $dom->loadXML( file_get_contents( $file ) );
    Line 269: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {
    fopen was found in the file parsers.php
    Line 415: $fp = $this->fopen( $file, 'r' );
    Line 641: function fopen( $filename, $mode = 'r' ) {
    Line 644: return fopen( $filename, $mode );
    fclose was found in the file parsers.php
    Line 464: $this->fclose($fp);
    Line 659: function fclose( $fp ) {
    Line 662: return fclose( $fp );
    fopen was found in the file parsers.php
    Line 415: $fp = $this->fopen( $file, 'r' );
    Line 641: function fopen( $filename, $mode = 'r' ) {
    Line 644: return fopen( $filename, $mode );
    fopen was found in the file parsers.php
    Line 415: $fp = $this->fopen( $file, 'r' );
    Line 641: function fopen( $filename, $mode = 'r' ) {
    Line 644: return fopen( $filename, $mode );
    fclose was found in the file parsers.php
    Line 464: $this->fclose($fp);
    Line 659: function fclose( $fp ) {
    Line 662: return fclose( $fp );
    fclose was found in the file parsers.php
    Line 464: $this->fclose($fp);
    Line 659: function fclose( $fp ) {
    Line 662: return fclose( $fp );
    fopen was found in the file qode-import.php
    Line 148: if( ini_get('allow_url_fopen') ) {
    Line 149: $qode_file_method = 'fopen';
    Line 153: if ( $qode_file_method == 'fopen' ) {
    Line 154: $qode_handle = fopen( $filepath, 'rb' );
    fread was found in the file qode-import.php
    Line 158: $qode_content .= fread($qode_handle, 8192);
    fclose was found in the file qode-import.php
    Line 160: fclose( $qode_handle );
    file_get_contents was found in the file qode-import.php
    Line 151: $qode_file_method = 'file_get_contents';
    Line 164: return file_get_contents($filepath);
    file_get_contents was found in the file font-awesome.php
    Line 11: $subject = file_get_contents(QODE_ROOT.'/css/font-awesome/css/font-awesome.css');
  6. Malware : Network operations fsockopen was found in the file recaptchalib.php
    Line 81: if( false == ( $fs = @fsockopen($host, $port, $errno, $errstr, 10) ) ) {
  7. Admin menu : Themes should use add_theme_page() for adding admin pages. File qode-import.php :
    Line 173: $this->pagehook = add_submenu_page('qode_options_theme13_page', 'Qode Theme', esc_html__('Qod
    File qode-options.php :
    Line 332: $this->pagehook = add_menu_page('Qode Theme', esc_html__('Qode Options', 'qode'), 'manage_opt
  8. Deprecated functions : wp_get_http wp_get_http found in file class.wordpress-importer.php. Deprecated since version 4.4. Use WP_Http instead.
    Line 998: $headers = wp_get_http( $url, $upload['file'] );
  9. Deprecated functions : get_bloginfo get_bloginfo('url') was found in the file qode-breadcrumbs.php. Use home_url() instead.
    Line 5: $homeLink = get_bloginfo('url');
  10. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was layersliderwp-6.6.4.installable.zip envato-market.zip js_composer.zip.
Warning
  1. theme tags : Presence of bad theme tagsFound wrong tag multi-purpose in style.css header.Found wrong tag clean in style.css header.Found wrong tag retina in style.css header.Found wrong tag responsive in style.css header.Found wrong tag corporate in style.css header.Found wrong tag parallax in style.css header.Found wrong tag mega menu in style.css header.Found wrong tag business in style.css header.Found wrong tag fullscreen in style.css header.Found wrong tag animations in style.css header.The tag white has been deprecated, it must be removed from style.css header.Found wrong tag creative in style.css header.Found wrong tag modern in style.css header.Found wrong tag ecommerce in style.css header.
  2. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function __, with the arguments 'Enter Name of the new Widget Area' in file qode-custom-sidebar.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Add Widget Area' in file qode-custom-sidebar.php.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are qode, taxonomy general name, taxonomy singular name, wordpress-importer, wordpress-importere, tgmpa, js_composer, text_domain, woocommerce.
  3. Plugin territory : Plugin territory functionalitiesThe theme uses the register_post_type() function, which is plugin-territory functionality.The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
  4. Custom elements : Presence of custom headerNo reference to custom header was found in the theme.
  5. Custom elements : Presence of custom backgroundNo reference to custom background was found in the theme.
  6. Editor style : Presence of editor styleNo reference to add_editor_style() was found in the theme. It is recommended that the theme implements editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  7. CSS files : Presence of text domainText Domain: is missing from your style.css header.
  8. Date and time implementation : Use of the_time()At least one hard coded date was found in the file blog_small_image-loop.php. Function get_option( 'date_format' ) should be used instead.
  9. Screenshot : Screenshot fileScreenshot size is 384x288px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  4. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  5. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  6. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  7. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  8. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  9. Use of includes : Use of include or requireThe theme appears to use include or require : qode-import.php
    Line 48: require_once($class_wp_importer);
    Line 49: require_once(get_template_directory() . '/includes/import/class.wordpress-i
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_separator_with_text.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_message.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_image_with_text_over.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_icon_list_item.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_cover_boxes.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_icons_text.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_progress_bar_icon.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_testimonials.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_image_hover.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_button.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_action.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_steps.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_image_with_text.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_qode_carousel.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_icons.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode-options.php
    Line 2: include_once('google-fonts.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ajax_mail.php
    Line 2: require_once('recaptchalib.php');
    Line 3: require('../../../../wp-blog-header.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode-menu.php
    Line 63: include_once('edit_custom_walker.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : footer.php
    Line 231: if(isset($qode_toolbar)) include('toolbar.php')
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : custom_js.php
    Line 4: require_once( $root.'/wp-load.php' );
    Line 5: require_once( $root.'/wp-config.php' );
    Line 9: require_once( $root.'/wp-load.php' );
    Line 10: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : default_dynamic.php
    Line 4: require_once( $root.'/wp-load.php' );
    Line 5: require_once( $root.'/wp-config.php' );
    Line 9: require_once( $root.'/wp-load.php' );
    Line 10: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : contact-page.php
    Line 95: require_once('includes/recaptchalib.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : style_dynamic_responsive.php
    Line 4: require_once( $root.'/wp-load.php' );
    Line 5: require_once( $root.'/wp-config.php' );
    Line 9: require_once( $root.'/wp-load.php' );
    Line 10: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : custom_css.php
    Line 4: require_once( $root.'/wp-load.php' );
    Line 6: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : style_dynamic.php
    Line 5: require_once( $root.'/wp-load.php' );
    Line 6: require_once( $root.'/wp-config.php' );
    Line 10: require_once( $root.'/wp-load.php' );
    Line 11: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.

This is a ThemeForest theme. Since Themeforest items are all checked by a human before they appear on their website, ThemeForest verification rules are more permissive than themecheck's and can give a better verification score ( Themeforest requirements ).

0
Critical alerts
  1. Title : Title No reference to add_theme_support( "title-tag" ) was found in the theme.The theme needs to have <title> tags, ideally in the header.php file.The theme needs to have a call to wp_title(), ideally in the header.php file.
  2. Malware : Network operations fsockopen was found in the file recaptchalib.php
    Line 81: if( false == ( $fs = @fsockopen($host, $port, $errno, $errstr, 10) ) ) {
  3. Deprecated functions : wp_get_http wp_get_http found in file class.wordpress-importer.php. Deprecated since version 4.4. Use WP_Http instead.
    Line 998: $headers = wp_get_http( $url, $upload['file'] );
  4. Deprecated functions : get_bloginfo get_bloginfo('url') was found in the file qode-breadcrumbs.php. Use home_url() instead.
    Line 5: $homeLink = get_bloginfo('url');
  5. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was layersliderwp-6.6.4.installable.zip envato-market.zip js_composer.zip.
Warning
  1. theme tags : Presence of bad theme tagsFound wrong tag multi-purpose in style.css header.Found wrong tag clean in style.css header.Found wrong tag retina in style.css header.Found wrong tag responsive in style.css header.Found wrong tag corporate in style.css header.Found wrong tag parallax in style.css header.Found wrong tag mega menu in style.css header.Found wrong tag business in style.css header.Found wrong tag fullscreen in style.css header.Found wrong tag animations in style.css header.The tag white has been deprecated, it must be removed from style.css header.Found wrong tag creative in style.css header.Found wrong tag modern in style.css header.Found wrong tag ecommerce in style.css header.
  2. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function __, with the arguments 'Enter Name of the new Widget Area' in file qode-custom-sidebar.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Add Widget Area' in file qode-custom-sidebar.php.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are qode, taxonomy general name, taxonomy singular name, wordpress-importer, wordpress-importere, tgmpa, js_composer, text_domain, woocommerce.
  3. Plugin territory : Plugin territory functionalitiesThe theme uses the register_post_type() function, which is plugin-territory functionality.The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
  4. CSS files : Presence of text domainText Domain: is missing from your style.css header.
  5. Date and time implementation : Use of the_time()At least one hard coded date was found in the file blog_small_image-loop.php. Function get_option( 'date_format' ) should be used instead.
  6. Screenshot : Screenshot fileScreenshot size is 384x288px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  4. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  5. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  6. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  7. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  8. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  9. Use of includes : Use of include or requireThe theme appears to use include or require : qode-import.php
    Line 48: require_once($class_wp_importer);
    Line 49: require_once(get_template_directory() . '/includes/import/class.wordpress-i
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_separator_with_text.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_message.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_image_with_text_over.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_icon_list_item.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_cover_boxes.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_icons_text.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_progress_bar_icon.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_testimonials.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_image_hover.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_button.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_action.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_steps.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_image_with_text.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_qode_carousel.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode_shortcodes_icons.php
    Line 4: require_once( $path[0] . '/wp-load.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode-options.php
    Line 2: include_once('google-fonts.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ajax_mail.php
    Line 2: require_once('recaptchalib.php');
    Line 3: require('../../../../wp-blog-header.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qode-menu.php
    Line 63: include_once('edit_custom_walker.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : footer.php
    Line 231: if(isset($qode_toolbar)) include('toolbar.php')
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : custom_js.php
    Line 4: require_once( $root.'/wp-load.php' );
    Line 5: require_once( $root.'/wp-config.php' );
    Line 9: require_once( $root.'/wp-load.php' );
    Line 10: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : default_dynamic.php
    Line 4: require_once( $root.'/wp-load.php' );
    Line 5: require_once( $root.'/wp-config.php' );
    Line 9: require_once( $root.'/wp-load.php' );
    Line 10: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : contact-page.php
    Line 95: require_once('includes/recaptchalib.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : style_dynamic_responsive.php
    Line 4: require_once( $root.'/wp-load.php' );
    Line 5: require_once( $root.'/wp-config.php' );
    Line 9: require_once( $root.'/wp-load.php' );
    Line 10: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : custom_css.php
    Line 4: require_once( $root.'/wp-load.php' );
    Line 6: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : style_dynamic.php
    Line 5: require_once( $root.'/wp-load.php' );
    Line 6: require_once( $root.'/wp-config.php' );
    Line 10: require_once( $root.'/wp-load.php' );
    Line 11: require_once( $root.'/wp-config.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes