15
Validation results

Rife

Rife

WordPress 4.8.2 theme
15
    Error 8 : Undefined index: slug
    In /home/www/themecheck/themecheck/controllers/controller_results.php line 772
  • THEME TYPEWordPress theme 4.8.2
  • FILE NAMErife.zip
  • FILE SIZE14728498 bytes
  • MD507d3f620ec98c73de6703ed691f580a4
  • SHA168777c7c0e23665cd072d2c92a943b63a6046abb
  • LICENSEGNU GPL 3
  • FILES INCLUDEDCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • THEME URIhttp://apollo13themes.com/themes
  • VERSION1.1.9.2
  • AUTHOR URI
  • TAGStheme-options, post-formats, two-columns, translation-ready
  • CREATION DATE2017-04-18
  • LAST FILE UPDATE2017-04-18
  • LAST VALIDATION2017-04-18 19:16
  • OTHER VERSIONS

    1.1.9.3 : 78%

Critical alerts
  1. Presence of iframes : iframes are sometimes used to load unwanted adverts and malicious code on another site Found <iframe data-vid-id="'.$video_data['video_id'].'" id="a13-crazy'.$type . mt_rand() . '" style="height: ' . $height . 'px; width: ' . $width . 'px; border: none;" src="' . esc_url($link) . '" allowfullscreen > in file media.php.
    Line 411: return '<iframe data-vid-id=''.$video_data['video_id'].'' id='a13-crazy'.$type . mt
  2. Malware : Network operations curl_init was found in the file rife.php
    Line 101: /*$curl = curl_init();
    curl_exec was found in the file rife.php
    Line 120: $response = curl_exec( $curl );
  3. Admin menu : Themes should use add_theme_page() for adding admin pages. File theme-options.php :
    Line 127: // For a full list of options, visit: http://codex.wordpress.org/Function_Reference/add_submenu_page#Parameters
  4. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was revslider.zip a13_framework_cpt.zip js_composer.zip.
Warning
  1. Text domain : Incorrect use of translation functions.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are apollo13-framework, rife, js_composer, woocommerce.
  2. Custom elements : Presence of custom headerNo reference to custom header was found in the theme.
  3. Custom elements : Presence of custom backgroundNo reference to custom background was found in the theme.
  4. Editor style : Presence of editor styleNo reference to add_editor_style() was found in the theme. It is recommended that the theme implements editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  5. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Static links : Presence of hard-coded linksPossible hard-coded links were found in the file rife.php.
    Line 34: <p><?php _e( 'Here you can add/update your license code for Rife.<br /> It will remove our banner from your admin panel.<br /> If you provide active license code then it will also enable auto updates of theme.', 'apollo13-framework' );?><br /><a href='http://apollo13themes.com/rife/license-code/' target='_blank'><?php _e( 'Re
    Possible hard-coded links were found in the file importer.php.
    Line 357: echo '<mark class='error'><span class='dashicons dashicons-no'></span> ' . sprintf( __( '%s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %s', 'apollo13-framework' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ
    Line 360: echo '<mark class='warning'><span class='dashicons dashicons-warning'></span> ' . sprintf( __( '%s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %s', 'apollo13-framework' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ
    Line 357: echo '<mark class='error'><span class='dashicons dashicons-no'></span> ' . sprintf( __( '%s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %s', 'apollo13-framework' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ
    Line 360: echo '<mark class='warning'><span class='dashicons dashicons-warning'></span> ' . sprintf( __( '%s - We recommend a minimum PHP version of 5.6. Having version 7 or higher is even better. See: %s', 'apollo13-framework' ), esc_html( $php_version ), '<a href='https://docs.woocommerce.com/document/how-to-update-your-php-version/' targ
  2. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  5. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  6. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  7. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  8. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  9. Optional files : Presence of archive template file archive.phpThis theme does not contain optional file archive.php.
  10. Optional files : Presence of search results template file search.phpThis theme does not contain optional file search.php.
  11. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  12. Use of includes : Use of include or requireThe theme appears to use include or require : rife.php
    Line 467: require_once(A13FRAMEWORK_TPL_ADV_DIR.'/inc/theme-update-checker.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : Apollo13Framework.php
    Line 116: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/admin/admin.php');
    Line 118: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/admin/admin_ajax.php');
    Line 120: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/admin/metaboxes.php');
    Line 122: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/admin/print_options.php');
    Line 151: require_once( A13FRAMEWORK_TPL_ADV_DIR . '/customizer.php' );
    Line 155: require_once( A13FRAMEWORK_TPL_ADV_DIR . '/vc_extend.php' );
    Line 159: require_once( A13FRAMEWORK_TPL_ADV_DIR . '/importer.php' );
    Line 163: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/mega_menu.php');
    Line 167: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/cpt_admin.php');
    Line 171: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/widgets.php');
    Line 175: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/head_scripts_styles.php');
    Line 179: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/_manager.php');
    Line 183: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/inc/class-tgm-plugin-activation.p
    Line 185: require_once(A13FRAMEWORK_TPL_PLUGINS_DIR . '/plugins-list.php');
    Line 189: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/inc/Apollo13_Image_Resize.php');
    Line 195: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/theme-options.php');//must be cal
    Line 199: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/inc/redux_extensions/sortable/fie
    Line 201: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/inc/redux_extensions/typography/f
    Line 208: require_once( A13FRAMEWORK_TPL_ADV_DIR . '/redux_fallback.php' );
    Line 618: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/meta.php');
    Line 751: require_once(ABSPATH . 'wp-admin/includes/template.php');
    Line 775: $css = include(A13FRAMEWORK_TPL_ADV_DIR . '/user-css.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : extension_advanced_customizer.php
    Line 163: include_once( $this->upload_dir . $option['type'] . '.php' );
    Line 171: //include_once( ReduxFramework::$_dir . 'core/enqueue.php' );
    Line 481: require_once( $class_file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : demo_data.php
    Line 227: $extra_plugins = require_once( $extra_plugins_file );
    Line 528: require_once( 'a13-wordpress-importer/wordpress-importer.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : admin.php
    Line 123: $classes = require_once(A13FRAMEWORK_TPL_ADV_DIR.'/inc/font-awesome-icons');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : admin_ajax.php
    Line 37: $file_system_check = require_once( A13FRAMEWORK_TPL_ADV_DIR . '/admin/demo_data.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : metaboxes.php
    Line 92: require_once (A13FRAMEWORK_TPL_ADV_DIR . '/meta.php');
    Line 256: require_once (A13FRAMEWORK_TPL_ADV_DIR . '/meta.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : plugins-list.php
    Line 63: require_once($special_plugins_file);
    Line 69: require_once($envy_plugins_file);
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : footer.php
    Line 263: include(A13FRAMEWORK_TPL_DIR.'/demo_chooser_links');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : _manager.php
    Line 6: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'cpt.php');
    Line 7: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'cpt_album.php');
    Line 8: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'cpt_work.php');
    Line 9: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'custom.php');
    Line 10: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'footer.php');
    Line 11: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'header.php');
    Line 12: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'layout_parts.php');
    Line 13: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'media.php');
    Line 14: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'menu.php');
    Line 15: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'not_pluggable.php');
    Line 16: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'posts.php');
    Line 17: require_once(A13FRAMEWORK_TPL_ADV_DIR . '/utilities/'.'woocommerce.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : head_scripts_styles.php
    Line 270: $css = include( A13FRAMEWORK_TPL_ADV_DIR . '/user-css.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : customizer.php
    Line 21: $classes = require_once(A13FRAMEWORK_TPL_ADV_DIR.'/inc/font-awesome-icons');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes