0
Validation results

North

North

WordPress 5.0.3 theme
0
Critical alerts
  1. Title : Title The <title> tags can only contain a call to wp_title(). Use the wp_title filter to modify the output.
  2. Security breaches : Use of base64_decode() Found base64_decode in file functions.interface.php.
    Line 221: $smof_data = unserialize(base64_decode($_POST['data'])); //100% safe - ignore theme check nag
  3. Security breaches : Use of base64_encode() Found base64_encode in file class.options_machine.php.
     $output .= '<textarea id='export_data' rows='8'>'.base64_encode(serialize($smof_data)) /* 100% safe - ignore theme check nag 
  4. Presence of iframes : iframes are sometimes used to load unwanted adverts and malicious code on another site Found <iframe src="http://player.vimeo.com/video/'.$vimeo.'?title=0&amp;byline=0&amp;portrait=0&amp;autoplay='.$autoplay.'&amp;loop=1&amp;muted=1" allow="autoplay; fullscreen" width="100%" height="100%" frameborder="0" webkitAllowFullScreen mozallowfullscreen allowFullScreen> in file vc_row.php.
    Line 287: <li><img src=''.get_template_directory_uri().'/img/empty.png' width='1' height='1' /><iframe src='http://player.vimeo.com/video/'.$vimeo.'?title=0&amp;byline=0&
  5. Admin menu : Themes should use add_theme_page() for adding admin pages. File class-tgm-plugin-activation.php :
    Line 731: $this->page_hook = call_user_func( 'add_submenu_page', $args['parent_slug'], $args['page_title'], $args['menu_t
    File functions.interface.php :
    Line 58: $of_page = call_user_func( 'add_menu_page', esc_html__( 'North', 'north' ), 'North', 'manage_options', 
  6. Deprecated functions : get_currentuserinfo get_currentuserinfo found in file vc_template_manager.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 749: get_currentuserinfo();
  7. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was carousel-team.php.zip vntd-twitter.zip revslider.zip twitter.zip js_composer.zip envato-wordpress-toolkit-master.zip templatera.zip vc_row.php.zip.
Warning
  1. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function __, with the arguments "north" in file vc_template_manager.php.
  2. Plugin territory : Plugin territory functionalitiesThe theme uses the register_post_type() function, which is plugin-territory functionality.The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
  3. Custom elements : Presence of custom headerNo reference to custom header was found in the theme.
  4. Custom elements : Presence of custom backgroundNo reference to custom background was found in the theme.
  5. Editor style : Presence of editor styleNo reference to add_editor_style() was found in the theme. It is recommended that the theme implements editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  6. I18N implementation : Proper use of _e(Possible variable $template found in translation function in new_editor.tpl.php. Translation function calls should not contain PHP variables.
    Line 46: <li class='wpb_template_li'><a href='#' data-template_name='<?php echo str_replace('.json','',basename($template['filename'])); ?>'><?php _e($template['name'],'north'); ?></a></li>
  7. I18N implementation : Proper use of ___all(Possible variable $title found in translation function in vc_template_manager.php. Translation function calls should not contain PHP variables.
    Line 154: echo '<option value='' . $key . ''' . ($value === $key ? ' selected='true'' : '') . '>' . __($title, 'north') . '</option>';
  8. Date and time implementation : Use of the_time()At least one hard coded date was found in the file blog-functions.php. Function get_option( 'date_format' ) should be used instead.
  9. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Static links : Presence of hard-coded linksPossible hard-coded links were found in the file templatera.php.
    Line 21: <p>' . sprintf(__('<strong>%s</strong> requires <strong><a href='http://bit.ly/vcomposer' target='_blank'>Visual Composer</a></strong> plugi
    Line 28: <p>' . sprintf(__('<strong>%s</strong> requires <strong>%s</strong> version of <strong><a href='http://bit.ly/vcomposer' target='_blank'>Visual Composer</a></strong> plugi
    Line 21: <p>' . sprintf(__('<strong>%s</strong> requires <strong><a href='http://bit.ly/vcomposer' target='_blank'>Visual Composer</a></strong> plugi
    Line 28: <p>' . sprintf(__('<strong>%s</strong> requires <strong>%s</strong> version of <strong><a href='http://bit.ly/vcomposer' target='_blank'>Visual Composer</a></strong> plugi
    Possible hard-coded links were found in the file vc_template_manager.php.
    Line 187: echo '<a href='export.php?page=wpb_vc_settings&action=export_templatera' class='button'>' 
  2. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  3. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  4. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  5. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  6. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  7. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  8. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  9. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  10. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  11. Use of includes : Use of include or requireThe theme appears to use include or require : widgets.php
    Line 7: include_once( VNTD_WIDGETS . '/lib/widget-flickr.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcodes.php
    Line 33: include_once( VNTD_SHORTCODES . '/lib/google-map.php' );
    Line 34: //include_once( VNTD_SHORTCODES . '/lib/blog.php');
    Line 35: include_once( VNTD_SHORTCODES . '/lib/carousel-portfolio.php' );
    Line 36: include_once( VNTD_SHORTCODES . '/lib/carousel-blog.php' );
    Line 37: include_once( VNTD_SHORTCODES . '/lib/carousel-team.php' );
    Line 38: include_once( VNTD_SHORTCODES . '/lib/carousel-testimonials.php' );
    Line 39: include_once( VNTD_SHORTCODES . '/lib/carousel-logos.php' );
    Line 40: include_once( VNTD_SHORTCODES . '/lib/carousel-services.php' );
    Line 41: include_once( VNTD_SHORTCODES . '/lib/accordion.php' );
    Line 42: include_once( VNTD_SHORTCODES . '/lib/button.php' );
    Line 43: include_once( VNTD_SHORTCODES . '/lib/counter.php' );
    Line 44: include_once( VNTD_SHORTCODES . '/lib/contact-block.php' );
    Line 45: include_once( VNTD_SHORTCODES . '/lib/contact-form.php' );
    Line 46: include_once( VNTD_SHORTCODES . '/lib/call-to-action.php' );
    Line 47: include_once( VNTD_SHORTCODES . '/lib/fancy-text-block.php' );
    Line 48: include_once( VNTD_SHORTCODES . '/lib/fullscreen-slider.php' );
    Line 49: include_once( VNTD_SHORTCODES . '/lib/icon.php' );
    Line 50: include_once( VNTD_SHORTCODES . '/lib/icon-box.php' );
    Line 51: include_once( VNTD_SHORTCODES . '/lib/list.php' );
    Line 52: include_once( VNTD_SHORTCODES . '/lib/portfolio-grid.php' );
    Line 53: include_once( VNTD_SHORTCODES . '/lib/portfolio-details.php' );
    Line 54: include_once( VNTD_SHORTCODES . '/lib/pricing-box.php' );
    Line 55: include_once( VNTD_SHORTCODES . '/lib/progress-bar.php' );
    Line 56: include_once( VNTD_SHORTCODES . '/lib/north-tabs.php' );
    Line 57: include_once( VNTD_SHORTCODES . '/lib/section.php' );
    Line 58: include_once( VNTD_SHORTCODES . '/lib/social-icons.php' );
    Line 59: include_once( VNTD_SHORTCODES . '/lib/tabs.php' );
    Line 60: include_once( VNTD_SHORTCODES . '/lib/team-member.php' );
    Line 61: include_once( VNTD_SHORTCODES . '/lib/toggle.php' );
    Line 62: include_once( VNTD_SHORTCODES . '/lib/video-lightbox.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-envato-wordpress-theme-upgrader.php
    Line 11: include_once( ABSPATH . 'wp-admin/includes/class-wp-upgrader.php' );
    Line 13: include_once( 'class-envato-protected-api.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : index.php
    Line 87: require_once ( ADMIN_PATH . 'functions/functions.load.php' );
    Line 88: require_once ( ADMIN_PATH . 'classes/class.options_machine.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vntd-admin-dynamic.php
    Line 17: require_once($wp_content . 'wp-load.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions.load.php
    Line 10: require_once( ADMIN_PATH . 'functions/functions.php' );
    Line 11: //require_once( ADMIN_PATH . 'functions/functions.filters.php' );
    Line 12: require_once( ADMIN_PATH . 'functions/functions.interface.php' );
    Line 13: require_once( ADMIN_PATH . 'functions/functions.admin.php' );
    Line 14: require_once( ADMIN_PATH . 'functions/functions.options.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions.interface.php
    Line 83: include_once( ADMIN_PATH . 'front-end/options.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vc-extend.php
    Line 2097: include_once(ABSPATH . 'wp-admin/includes/plugin.php'); // Require plugin.p
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : templatera.php
    Line 37: require_once($dir . '/lib/vc_template_manager.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : style-dynamic.php
    Line 17: require_once($wp_content . 'wp-load.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.

This is a ThemeForest theme. Since Themeforest items are all checked by a human before they appear on their website, ThemeForest verification rules are more permissive than themecheck's and can give a better verification score ( Themeforest requirements ).

36
Critical alerts
  1. Title : Title The <title> tags can only contain a call to wp_title(). Use the wp_title filter to modify the output.
  2. Deprecated functions : get_currentuserinfo get_currentuserinfo found in file vc_template_manager.php. Deprecated since version 4.5. Use wp_get_current_user instead.
    Line 749: get_currentuserinfo();
  3. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was carousel-team.php.zip vntd-twitter.zip revslider.zip twitter.zip js_composer.zip envato-wordpress-toolkit-master.zip templatera.zip vc_row.php.zip.
Warning
  1. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function __, with the arguments "north" in file vc_template_manager.php.
  2. Plugin territory : Plugin territory functionalitiesThe theme uses the register_post_type() function, which is plugin-territory functionality.The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
  3. Date and time implementation : Use of the_time()At least one hard coded date was found in the file blog-functions.php. Function get_option( 'date_format' ) should be used instead.
  4. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Static links : Presence of hard-coded linksPossible hard-coded links were found in the file templatera.php.
    Line 21: <p>' . sprintf(__('<strong>%s</strong> requires <strong><a href='http://bit.ly/vcomposer' target='_blank'>Visual Composer</a></strong> plugi
    Line 28: <p>' . sprintf(__('<strong>%s</strong> requires <strong>%s</strong> version of <strong><a href='http://bit.ly/vcomposer' target='_blank'>Visual Composer</a></strong> plugi
    Line 21: <p>' . sprintf(__('<strong>%s</strong> requires <strong><a href='http://bit.ly/vcomposer' target='_blank'>Visual Composer</a></strong> plugi
    Line 28: <p>' . sprintf(__('<strong>%s</strong> requires <strong>%s</strong> version of <strong><a href='http://bit.ly/vcomposer' target='_blank'>Visual Composer</a></strong> plugi
    Possible hard-coded links were found in the file vc_template_manager.php.
    Line 187: echo '<a href='export.php?page=wpb_vc_settings&action=export_templatera' class='button'>' 
  2. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  3. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  4. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  5. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  6. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  7. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  8. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  9. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  10. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  11. Use of includes : Use of include or requireThe theme appears to use include or require : widgets.php
    Line 7: include_once( VNTD_WIDGETS . '/lib/widget-flickr.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcodes.php
    Line 33: include_once( VNTD_SHORTCODES . '/lib/google-map.php' );
    Line 34: //include_once( VNTD_SHORTCODES . '/lib/blog.php');
    Line 35: include_once( VNTD_SHORTCODES . '/lib/carousel-portfolio.php' );
    Line 36: include_once( VNTD_SHORTCODES . '/lib/carousel-blog.php' );
    Line 37: include_once( VNTD_SHORTCODES . '/lib/carousel-team.php' );
    Line 38: include_once( VNTD_SHORTCODES . '/lib/carousel-testimonials.php' );
    Line 39: include_once( VNTD_SHORTCODES . '/lib/carousel-logos.php' );
    Line 40: include_once( VNTD_SHORTCODES . '/lib/carousel-services.php' );
    Line 41: include_once( VNTD_SHORTCODES . '/lib/accordion.php' );
    Line 42: include_once( VNTD_SHORTCODES . '/lib/button.php' );
    Line 43: include_once( VNTD_SHORTCODES . '/lib/counter.php' );
    Line 44: include_once( VNTD_SHORTCODES . '/lib/contact-block.php' );
    Line 45: include_once( VNTD_SHORTCODES . '/lib/contact-form.php' );
    Line 46: include_once( VNTD_SHORTCODES . '/lib/call-to-action.php' );
    Line 47: include_once( VNTD_SHORTCODES . '/lib/fancy-text-block.php' );
    Line 48: include_once( VNTD_SHORTCODES . '/lib/fullscreen-slider.php' );
    Line 49: include_once( VNTD_SHORTCODES . '/lib/icon.php' );
    Line 50: include_once( VNTD_SHORTCODES . '/lib/icon-box.php' );
    Line 51: include_once( VNTD_SHORTCODES . '/lib/list.php' );
    Line 52: include_once( VNTD_SHORTCODES . '/lib/portfolio-grid.php' );
    Line 53: include_once( VNTD_SHORTCODES . '/lib/portfolio-details.php' );
    Line 54: include_once( VNTD_SHORTCODES . '/lib/pricing-box.php' );
    Line 55: include_once( VNTD_SHORTCODES . '/lib/progress-bar.php' );
    Line 56: include_once( VNTD_SHORTCODES . '/lib/north-tabs.php' );
    Line 57: include_once( VNTD_SHORTCODES . '/lib/section.php' );
    Line 58: include_once( VNTD_SHORTCODES . '/lib/social-icons.php' );
    Line 59: include_once( VNTD_SHORTCODES . '/lib/tabs.php' );
    Line 60: include_once( VNTD_SHORTCODES . '/lib/team-member.php' );
    Line 61: include_once( VNTD_SHORTCODES . '/lib/toggle.php' );
    Line 62: include_once( VNTD_SHORTCODES . '/lib/video-lightbox.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-envato-wordpress-theme-upgrader.php
    Line 11: include_once( ABSPATH . 'wp-admin/includes/class-wp-upgrader.php' );
    Line 13: include_once( 'class-envato-protected-api.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : index.php
    Line 87: require_once ( ADMIN_PATH . 'functions/functions.load.php' );
    Line 88: require_once ( ADMIN_PATH . 'classes/class.options_machine.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vntd-admin-dynamic.php
    Line 17: require_once($wp_content . 'wp-load.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions.load.php
    Line 10: require_once( ADMIN_PATH . 'functions/functions.php' );
    Line 11: //require_once( ADMIN_PATH . 'functions/functions.filters.php' );
    Line 12: require_once( ADMIN_PATH . 'functions/functions.interface.php' );
    Line 13: require_once( ADMIN_PATH . 'functions/functions.admin.php' );
    Line 14: require_once( ADMIN_PATH . 'functions/functions.options.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions.interface.php
    Line 83: include_once( ADMIN_PATH . 'front-end/options.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vc-extend.php
    Line 2097: include_once(ABSPATH . 'wp-admin/includes/plugin.php'); // Require plugin.p
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : templatera.php
    Line 37: require_once($dir . '/lib/vc_template_manager.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : style-dynamic.php
    Line 17: require_once($wp_content . 'wp-load.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes