35
Validation results

North

North

WordPress 4.9.8 theme
35
Critical alerts
  1. Malware : Operations on file system fopen was found in the file download_emails.php
    Line 9: $fh = @fopen( 'php://output', 'w' );
    fclose was found in the file download_emails.php
    Line 23: fclose( $fh );
  2. Admin menu : Themes should use add_theme_page() for adding admin pages. File OneClickDemoImport.php :
    Line 138: $this->plugin_page = add_submenu_page(
    File fuelthemes.php :
    Line 557: add_menu_page( Thb_Theme_Admin::$thb_theme_name, Thb_Theme_Admin::$thb_them
    File fuelthemes.php :
    Line 560: add_submenu_page( 'thb-product-registration', 'Registration', 'Registration
    Line 563: add_submenu_page( 'thb-product-registration', 'Plugins', 'Plugins', 'edit_t
    Line 566: add_submenu_page( 'thb-product-registration', 'Demo Import', 'Demo Import',
    Line 569: add_submenu_page( 'thb-product-registration', 'Theme Options', 'Theme Optio
    File fuelthemes.php :
    Line 560: add_submenu_page( 'thb-product-registration', 'Registration', 'Registration
    Line 563: add_submenu_page( 'thb-product-registration', 'Plugins', 'Plugins', 'edit_t
    Line 566: add_submenu_page( 'thb-product-registration', 'Demo Import', 'Demo Import',
    Line 569: add_submenu_page( 'thb-product-registration', 'Theme Options', 'Theme Optio
    File fuelthemes.php :
    Line 560: add_submenu_page( 'thb-product-registration', 'Registration', 'Registration
    Line 563: add_submenu_page( 'thb-product-registration', 'Plugins', 'Plugins', 'edit_t
    Line 566: add_submenu_page( 'thb-product-registration', 'Demo Import', 'Demo Import',
    Line 569: add_submenu_page( 'thb-product-registration', 'Theme Options', 'Theme Optio
    File fuelthemes.php :
    Line 560: add_submenu_page( 'thb-product-registration', 'Registration', 'Registration
    Line 563: add_submenu_page( 'thb-product-registration', 'Plugins', 'Plugins', 'edit_t
    Line 566: add_submenu_page( 'thb-product-registration', 'Demo Import', 'Demo Import',
    Line 569: add_submenu_page( 'thb-product-registration', 'Theme Options', 'Theme Optio
  3. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was codecanyon-2751380-slider-revolution-responsive-wordpress-plugin-wordpress-plugin.zip codecanyon-242431-visual-composer-page-builder-for-wordpress-wordpress-plugin.zip.
Warning
  1. Text domain : Incorrect use of translation functions.Wrong installation directory for the theme name. The directory name must match the slug of the theme. This theme's correct slug and text-domain is north.
  2. Text domain : Incorrect use of translation functions.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are north, woocommerce, tgmpa, option-tree.
  3. Cdn : Use of CDNFound the URL of a CDN in the code: maxcdn.bootstrapcdn.com/font-awesome. CSS or Javascript resources should not be loaded from a CDN. These resources should be bundled with the theme.
  4. Plugin territory : Plugin territory functionalitiesThe theme uses the register_taxonomy() function, which is plugin-territory functionality.
  5. Custom elements : Presence of custom headerNo reference to custom header was found in the theme.
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  5. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  6. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  7. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  8. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  9. Optional files : Presence of archive template file archive.phpThis theme does not contain optional file archive.php.
  10. Optional files : Presence of search results template file search.phpThis theme does not contain optional file search.php.
  11. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  12. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  13. Use of includes : Use of include or requireThe theme appears to use include or require : CustomizerImporter.php
    Line 186: require_once( ABSPATH . 'wp-admin/includes/media.php' );
    Line 187: require_once( ABSPATH . 'wp-admin/includes/file.php' );
    Line 188: require_once( ABSPATH . 'wp-admin/includes/image.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : header.php
    Line 7: <?php include 'tabs.php'; ?>
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : plugins.php
    Line 2: <?php include 'header.php'; ?>
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : registration.php
    Line 2: <?php include 'header.php'; ?>
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : demo-import.php
    Line 2: <?php include 'header.php'; ?>
    Line 21: include 'requirements.php'; 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ot-functions-docs-page.php
    Line 751: require( trailingslashit( get_template_directory() ) . \'includes/meta-boxe
    Line 834: require( trailingslashit( get_template_directory() ) . \'option-tree/ot-loa
    Line 851: require( trailingslashit( get_template_directory() ) . \'includes/theme-opt
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ot-loader.php
    Line 541: require( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.

This is a ThemeForest theme. Since Themeforest items are all checked by a human before they appear on their website, ThemeForest verification rules are more permissive than themecheck's and can give a better verification score ( Themeforest requirements ).

76
Critical alerts
  1. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was codecanyon-2751380-slider-revolution-responsive-wordpress-plugin-wordpress-plugin.zip codecanyon-242431-visual-composer-page-builder-for-wordpress-wordpress-plugin.zip.
Warning
  1. Text domain : Incorrect use of translation functions.Wrong installation directory for the theme name. The directory name must match the slug of the theme. This theme's correct slug and text-domain is north.
  2. Text domain : Incorrect use of translation functions.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are north, woocommerce, tgmpa, option-tree.
  3. Cdn : Use of CDNFound the URL of a CDN in the code: maxcdn.bootstrapcdn.com/font-awesome. CSS or Javascript resources should not be loaded from a CDN. These resources should be bundled with the theme.
  4. Plugin territory : Plugin territory functionalitiesThe theme uses the register_taxonomy() function, which is plugin-territory functionality.
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  5. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  6. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  7. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  8. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  9. Optional files : Presence of archive template file archive.phpThis theme does not contain optional file archive.php.
  10. Optional files : Presence of search results template file search.phpThis theme does not contain optional file search.php.
  11. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  12. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  13. Use of includes : Use of include or requireThe theme appears to use include or require : CustomizerImporter.php
    Line 186: require_once( ABSPATH . 'wp-admin/includes/media.php' );
    Line 187: require_once( ABSPATH . 'wp-admin/includes/file.php' );
    Line 188: require_once( ABSPATH . 'wp-admin/includes/image.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : header.php
    Line 7: <?php include 'tabs.php'; ?>
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : plugins.php
    Line 2: <?php include 'header.php'; ?>
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : registration.php
    Line 2: <?php include 'header.php'; ?>
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : demo-import.php
    Line 2: <?php include 'header.php'; ?>
    Line 21: include 'requirements.php'; 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ot-functions-docs-page.php
    Line 751: require( trailingslashit( get_template_directory() ) . \'includes/meta-boxe
    Line 834: require( trailingslashit( get_template_directory() ) . \'option-tree/ot-loa
    Line 851: require( trailingslashit( get_template_directory() ) . \'includes/theme-opt
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ot-loader.php
    Line 541: require( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes