78
Validation results

ibloga

ibloga

WordPress 4.9.8 theme
78
  • THEME TYPEWordPress theme 4.9.8
  • FILE NAME01_iBloga_v.1.0.1.zip
  • FILE SIZE8977144 bytes
  • MD533b58f621e2b1e503904df170c150767
  • SHA1a31c051c7fe37b322c52d933302b98d49f9afdc3
  • LICENSECustom
  • FILES INCLUDEDCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • THEMEFOREST PAGEhttps://themeforest.net/item/ibloga-creative-multipurpose-blogportfolio-wordpress-theme/15859129 ($44)
  • VERSION1.0.1
  • AUTHOR URI
  • TAGSone-column, two-columns, three-columns, right-sidebar, left-sidebar, custom-background, custom-colors, custom-menu, featured-images, flexible-header, rtl-language-support, sticky-post, threaded-comments, translation-ready
  • CREATION DATE2018-08-05
  • LAST FILE UPDATE2018-08-05
  • LAST VALIDATION2018-08-05 15:15
Critical alerts
  1. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was ang-theme-assembler.zip ang-mega-slideshow.zip ang-ya-share.zip ang-breadcrumbs-and-title.zip ang-new-fieldgroup.zip js_composer.zip ang-most-popular-posts.zip ang-add-new-field.zip tt-warp7.zip.
Warning
  1. Text domain : Incorrect use of translation functions.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are tgmpa, ibloga.
  2. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual PNG file. Detected type was : "image/jpeg".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  5. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  6. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  7. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  8. Optional files : Presence of archive template file archive.phpThis theme does not contain optional file archive.php.
  9. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : plugin_activation.php
    Line 16: require_once( get_template_directory() . '/includes/class-tgm-plugin-activa
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : index.php
    Line 15: $warp = require(get_template_directory().'/warp.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : footer.php
    Line 15: $warp = require(get_template_directory().'/warp.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : init.php
    Line 33: require_once( BEANS_API_PATH . 'utilities/functions.php' );
    Line 34: require_once( BEANS_API_PATH . 'utilities/deprecated.php' );
    Line 35: require_once( BEANS_API_PATH . 'components.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : components.php
    Line 115: require_once( $component_path );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions-admin.php
    Line 72: require_once( BEANS_API_PATH . 'term-meta/class.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-compiler.php
    Line 101: require_once( ABSPATH . '/wp-admin/includes/file.php' );
    Line 439: require_once( BEANS_API_PATH . 'compiler/vendors/lessc.php' );
    Line 455: require_once( BEANS_API_PATH . 'compiler/vendors/js-minifier.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : gzip.php
    Line 48: include( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class.php
    Line 179: require_once( BEANS_API_PATH . 'fields/types/field.php' );
    Line 202: require_once( $path );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions-admin.php
    Line 35: *                                 'page template slug(s)' must include '.php' file extention. Set to true to display everywhere.
    Line 85: require_once( BEANS_API_PATH . 'post-meta/class.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : init.php
    Line 65: require_once( BEANS_API_PATH . 'init.php' );
    Line 138: require_once( BEANS_ADMIN_PATH . 'options.php' );
    Line 139: require_once( BEANS_ADMIN_PATH . 'updater.php' );
    Line 144: require_once( BEANS_ASSETS_PATH . 'assets.php' );
    Line 148: require_once( BEANS_ADMIN_PATH . 'wp-customize.php' );
    Line 151: require_once( BEANS_RENDER_PATH . 'template-parts.php' );
    Line 152: require_once( BEANS_RENDER_PATH . 'fragments.php' );
    Line 153: require_once( BEANS_RENDER_PATH . 'widget-area.php' );
    Line 154: require_once( BEANS_RENDER_PATH . 'walker.php' );
    Line 155: require_once( BEANS_RENDER_PATH . 'menu.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : template-parts.php
    Line 37: require( BEANS_STRUCTURE_PATH . 'header-partial.php' );
    Line 55: require_once( BEANS_STRUCTURE_PATH . 'content.php' );
    Line 92: require( BEANS_STRUCTURE_PATH . 'loop.php' );
    Line 135: require( BEANS_STRUCTURE_PATH . 'comment.php' );
    Line 153: require( BEANS_STRUCTURE_PATH . 'widget-area.php' );
    Line 209: require( BEANS_STRUCTURE_PATH . 'footer-partial.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : warp.php
    Line 22: require_once(WP_PLUGIN_DIR.'/tt-warp7/warp/src/Warp/Autoload/ClassLoader.ph
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : comments.php
    Line 15: $warp = require(get_template_directory().'/warp.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : theme.php
    Line 13: include($this['path']->path('layouts:theme.config.php'));
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : 404.php
    Line 15: $warp = require(get_template_directory().'/warp.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.

This is a ThemeForest theme. Since Themeforest items are all checked by a human before they appear on their website, ThemeForest verification rules are more permissive than themecheck's and can give a better verification score ( Themeforest requirements ).

78
  • THEME TYPEWordPress theme 4.9.8
  • FILE NAME01_iBloga_v.1.0.1.zip
  • FILE SIZE8977144 bytes
  • MD533b58f621e2b1e503904df170c150767
  • SHA1a31c051c7fe37b322c52d933302b98d49f9afdc3
  • LICENSECustom
  • FILES INCLUDEDCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • THEMEFOREST PAGEhttps://themeforest.net/item/ibloga-creative-multipurpose-blogportfolio-wordpress-theme/15859129 ($44)
  • VERSION1.0.1
  • AUTHOR URI
  • TAGSone-column, two-columns, three-columns, right-sidebar, left-sidebar, custom-background, custom-colors, custom-menu, featured-images, flexible-header, rtl-language-support, sticky-post, threaded-comments, translation-ready
  • CREATION DATE2018-08-05
  • LAST FILE UPDATE2018-08-05
  • LAST VALIDATION2018-08-05 15:15
Critical alerts
  1. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was ang-theme-assembler.zip ang-mega-slideshow.zip ang-ya-share.zip ang-breadcrumbs-and-title.zip ang-new-fieldgroup.zip js_composer.zip ang-most-popular-posts.zip ang-add-new-field.zip tt-warp7.zip.
Warning
  1. Text domain : Incorrect use of translation functions.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are tgmpa, ibloga.
  2. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual PNG file. Detected type was : "image/jpeg".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  4. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  5. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  6. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  7. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  8. Optional files : Presence of archive template file archive.phpThis theme does not contain optional file archive.php.
  9. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : plugin_activation.php
    Line 16: require_once( get_template_directory() . '/includes/class-tgm-plugin-activa
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : index.php
    Line 15: $warp = require(get_template_directory().'/warp.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : footer.php
    Line 15: $warp = require(get_template_directory().'/warp.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : init.php
    Line 33: require_once( BEANS_API_PATH . 'utilities/functions.php' );
    Line 34: require_once( BEANS_API_PATH . 'utilities/deprecated.php' );
    Line 35: require_once( BEANS_API_PATH . 'components.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : components.php
    Line 115: require_once( $component_path );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions-admin.php
    Line 72: require_once( BEANS_API_PATH . 'term-meta/class.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-compiler.php
    Line 101: require_once( ABSPATH . '/wp-admin/includes/file.php' );
    Line 439: require_once( BEANS_API_PATH . 'compiler/vendors/lessc.php' );
    Line 455: require_once( BEANS_API_PATH . 'compiler/vendors/js-minifier.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : gzip.php
    Line 48: include( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class.php
    Line 179: require_once( BEANS_API_PATH . 'fields/types/field.php' );
    Line 202: require_once( $path );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions-admin.php
    Line 35: *                                 'page template slug(s)' must include '.php' file extention. Set to true to display everywhere.
    Line 85: require_once( BEANS_API_PATH . 'post-meta/class.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : init.php
    Line 65: require_once( BEANS_API_PATH . 'init.php' );
    Line 138: require_once( BEANS_ADMIN_PATH . 'options.php' );
    Line 139: require_once( BEANS_ADMIN_PATH . 'updater.php' );
    Line 144: require_once( BEANS_ASSETS_PATH . 'assets.php' );
    Line 148: require_once( BEANS_ADMIN_PATH . 'wp-customize.php' );
    Line 151: require_once( BEANS_RENDER_PATH . 'template-parts.php' );
    Line 152: require_once( BEANS_RENDER_PATH . 'fragments.php' );
    Line 153: require_once( BEANS_RENDER_PATH . 'widget-area.php' );
    Line 154: require_once( BEANS_RENDER_PATH . 'walker.php' );
    Line 155: require_once( BEANS_RENDER_PATH . 'menu.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : template-parts.php
    Line 37: require( BEANS_STRUCTURE_PATH . 'header-partial.php' );
    Line 55: require_once( BEANS_STRUCTURE_PATH . 'content.php' );
    Line 92: require( BEANS_STRUCTURE_PATH . 'loop.php' );
    Line 135: require( BEANS_STRUCTURE_PATH . 'comment.php' );
    Line 153: require( BEANS_STRUCTURE_PATH . 'widget-area.php' );
    Line 209: require( BEANS_STRUCTURE_PATH . 'footer-partial.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : warp.php
    Line 22: require_once(WP_PLUGIN_DIR.'/tt-warp7/warp/src/Warp/Autoload/ClassLoader.ph
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : comments.php
    Line 15: $warp = require(get_template_directory().'/warp.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : theme.php
    Line 13: include($this['path']->path('layouts:theme.config.php'));
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : 404.php
    Line 15: $warp = require(get_template_directory().'/warp.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes