74
Validation results

EcoNature

EcoNature

WordPress 5.0.3 theme
74
  • THEME TYPEWordPress theme 5.0.3
  • FILE NAMEeconature.zip
  • FILE SIZE14128419 bytes
  • MD5da7c760d0e34132361d71140cd0f16fc
  • SHA122a31ceb6dabde462dc2c3c6252a5731dd8525f5
  • LICENSENone
  • FILES INCLUDEDCSS, PHP, XML, Bitmap images, Adobe Illustrator
  • THEME URIhttp://eco-nature.cmsmasters.net/
  • VERSION1.3.8
  • AUTHOR URI
  • TAGSone-column, two-columns, three-columns, four-columns, left-sidebar, right-sidebar, custom-background, custom-colors, custom-header, custom-menu, editor-style, featured-image-header, featured-images, flexible-header, full-width-template, microformats, post-formats, rtl-language-support, sticky-post, theme-options, threaded-comments, translation-ready
  • CREATION DATE2018-10-28
  • LAST FILE UPDATE2018-10-28
  • LAST VALIDATION2018-10-28 10:43
Critical alerts
  1. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was cmsms-contact-form-builder.zip cmsms-mega-menu.zip revslider.zip layerslider.zip envato-market.zip cmsms-content-composer.zip.
Warning
  1. Text domain : Incorrect use of translation functions.Wrong installation directory for the theme name. The directory name must match the slug of the theme. This theme's correct slug and text-domain is econature.
  2. Text domain : Incorrect use of translation functions.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are econature, the-events-calendar, tribe-events-calendar-pro, woocommerce.
  3. Custom elements : Presence of custom headerNo reference to custom header was found in the theme.
  4. Custom elements : Presence of custom backgroundNo reference to custom background was found in the theme.
  5. I18N implementation : Proper use of _ex(Possible variable $ci found in translation function in twitteroauth.php. Translation function calls should not contain PHP variables.
    Line 235: $response = $cl_ex($ci);
  6. Screenshot : Screenshot fileScreenshot size is 880x660px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual PNG file. Detected type was : "image/jpeg".
Tip-off
  1. Static links : Presence of hard-coded linksPossible hard-coded links were found in the file template-functions.php.
    Line 888: <a href='https://twitter.com/share' class='twitter-share-button' data-lang='en'><?ph
    Possible hard-coded links were found in the file widgets.php.
    Line 675: <label for='<?php echo $this->get_field_id('user'); ?>'><?php _e('Flickr ID', 'econature'); ?> (<a href='http://www.idgettr.com' target='_blank'>idGettr</a>):<br />
  2. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  3. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  4. Optional files : Presence of home template file home.phpThis theme does not contain optional file home.php.
  5. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  6. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  7. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  8. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  9. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : theme-functions.php
    Line 776: require_once(ABSPATH . '/wp-admin/includes/file.php');
    Line 1216: require_once(ABSPATH . '/wp-admin/includes/file.php');
    Line 1242: require_once(ABSPATH . '/wp-admin/includes/file.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : twitteroauth.php
    Line 16: require_once('OAuth.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : cmsms-theme-settings.php
    Line 20: require_once(CMSMS_SETTINGS . '/inc/cmsms-helper-functions.php');
    Line 21: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-general.php');
    Line 22: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-style.php');
    Line 23: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-font.php');
    Line 24: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-color.php');
    Line 25: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-single.php');
    Line 26: require_once(CMSMS_SETTINGS . '/cmsms-theme-settings-demo.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : cmsms-theme-options.php
    Line 13: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-general.php');
    Line 14: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-post.php');
    Line 15: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-page.php');
    Line 16: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-project.php');
    Line 17: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-profile.php');
    Line 18: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-other.php');
    Line 19: require_once(CMSMS_OPTIONS . '/cmsms-theme-options-product.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : options-importer.php
    Line 15: require_once($parse_uri[0] . 'wp-load.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes