0
Validation results

Boldial

Boldial

WordPress 4.9.4 theme
0
  • THEME TYPEWordPress theme 4.9.4
  • FILE NAMEboldial.zip
  • FILE SIZE11427448 bytes
  • MD54c662f8dd6c4aedfd687ed12b66c74a1
  • SHA1b536fd83a6da8306b887b30cf92cea7704dcc604
  • LICENSEGNU GPL 2
  • FILES INCLUDEDCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • THEMEFOREST PAGEhttps://themeforest.net/item/boldial-wp-flat-creative-theme-with-3d-portfolio/7771632 ($59)
  • VERSION2.8
  • AUTHOR URI
  • TAGSblack, blue, brown, gray, green, orange, pink, purple, red, silver, tan, white, yellow, dark, light, one-column, two-columns, three-columns, four-columns, right-sidebar, flexible-width, custom-background, custom-colors, custom-header, custom-menu, editor-style, featured-image-header, featured-images, full-width-template, microformats, post-formats, theme-options, threaded-comments, translation-ready, holiday, photoblogging, seasonal
  • CREATION DATE2018-02-13
  • LAST FILE UPDATE2018-02-13
  • LAST VALIDATION2018-02-13 07:32
  • OTHER VERSIONS

    2.1 : 0%

Critical alerts
  1. Title : Title No reference to add_theme_support( "title-tag" ) was found in the theme.The theme needs to have <title> tags, ideally in the header.php file.The theme needs to have a call to wp_title(), ideally in the header.php file.The <title> tags can only contain a call to wp_title(). Use the wp_title filter to modify the output.
  2. Security breaches : Use of base64_decode() Found base64_decode in file helpers_factory.php.
    Line 276: $value = preg_match( '/^#E\-8_/', $value ) ? rawurldecode( base64_decode( preg_replace( '/^#E\-8_/', '', $value ) ) ) : $value;
    Found base64_decode in file default_params.php.
    Line 246: . htmlentities( rawurldecode( base64_decode( $value ) ), ENT_COMPAT, 'UTF-8' ) . '</textarea>';
    Found base64_decode in file vc-raw-html.php.
    Line 44: $output .= '<' . $param['holder'] . ' class='wpb_vc_param_value ' . $param_name . ' ' . $type . ' ' . $class . '' name='' . $param_name . ''>' . htmlentities( rawurldecode( base64_decode( strip_tags( $value ) ) ), ENT_COMPAT, 'UTF-8' ) . '</' . $pa
    Found base64_decode in file vc-raw-js.php.
    Line 23: $content = rawurldecode( base64_decode( strip_tags( $content ) ) );
    Found base64_decode in file vc_raw_html.php.
    Line 20: $content = rawurldecode( base64_decode( strip_tags( $content ) ) );
    Found base64_decode in file functions.interface.php.
    Line 265: $ish_options = unserialize(base64_decode($ish_options)); //100% safe - ignore theme check nag
  3. Security breaches : Use of base64_encode() Found base64_encode in file vc-image-filters.php.
     $response['data']['src'] = 'data:image/' . $extension . ';base64,' . base64_encode( $data );
    Found base64_encode in file shortcode-vc-raw-html.php.
     'value' => base64_encode( '<p>I am raw html block.<br/>Click edit button to change thi
    Found base64_encode in file shortcode-vc-raw-js.php.
     'value' => __( base64_encode( '<script type='text/javascript'> alert('Enter your js here!'
    Found base64_encode in file class.options_machine.php.
     $output .= '<textarea id='export_data' rows='8'>'.base64_encode(serialize($ish_options)) /* 100% safe - ignore theme check na
  4. Presence of iframes : iframes are sometimes used to load unwanted adverts and malicious code on another site Found <iframe src="//www.facebook.com/plugins/like.php?href=' . $url . '&amp;layout=' . $type . '&amp;show_faces=false&amp;action=like&amp;colorscheme=light" scrolling="no" frameborder="0" allowTransparency="true"> in file vc_facebook.php. Found <iframe width="100%" height="' . $size . '" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="' . $link . '&amp;t=' . $type . '&amp;z=' . $zoom . '&amp;output=embed' . $bubble . '"> in file vc_gmaps.php.
    Line 64: echo '<iframe width='100%' height='' . $size . '' frameborder='0' scrolling='no' 
    Found <iframe width="500" height="281" src="//www.youtube.com/embed/sBvEiIL6Blo" frameborder="0" allowfullscreen> in file vc-grid-item-editor.php.
    Line 214: 'content' => sprintf( '<h3> %s </h3> %s', __( 'Watch Video Tutorial', 'js_composer' ), '<p>' . __( 'Have a look how easy it is to work with grid element builder.', 'js_composer' ) . '</p>' . '<iframe width='500' height='281' src='//www.youtube.com/embed/sBvEiIL6Blo' 
    Found <iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d6304.829986131271!2d-122.4746968033092!3d37.80374752160443!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x808586e6302615a1%3A0x86bd130251757c00!2sStorey+Ave%2C+San+Francisco%2C+CA+94129!5e0!3m2!1sen!2sus!4v1435826432051" width="600" height="450" frameborder="0" style="border:0" allowfullscreen> in file shortcode-vc-gmaps.php.
    Line 23: 'value' => '<iframe src='https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d6304.829
  5. Malware : Operations on file system file_get_contents was found in the file helpers_factory.php
    Line 414: function vc_file_get_contents( $filename, $partial = false ) {
    Line 431: $output = file_get_contents( $filename );
    file_get_contents was found in the file parsers.php
    Line 74: $success = $dom->loadXML( file_get_contents( $file ) );
    Line 345: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {
    file_get_contents was found in the file parsers.php
    Line 74: $success = $dom->loadXML( file_get_contents( $file ) );
    Line 345: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {
    fopen was found in the file parsers.php
    Line 522: $fp = $this->fopen( $file, 'r' );
    Line 765: function fopen( $filename, $mode = 'r' ) {
    Line 770: return fopen( $filename, $mode );
    fclose was found in the file parsers.php
    Line 572: $this->fclose( $fp );
    Line 789: function fclose( $fp ) {
    Line 794: return fclose( $fp );
    fopen was found in the file parsers.php
    Line 522: $fp = $this->fopen( $file, 'r' );
    Line 765: function fopen( $filename, $mode = 'r' ) {
    Line 770: return fopen( $filename, $mode );
    fopen was found in the file parsers.php
    Line 522: $fp = $this->fopen( $file, 'r' );
    Line 765: function fopen( $filename, $mode = 'r' ) {
    Line 770: return fopen( $filename, $mode );
    fclose was found in the file parsers.php
    Line 572: $this->fclose( $fp );
    Line 789: function fclose( $fp ) {
    Line 794: return fclose( $fp );
    fclose was found in the file parsers.php
    Line 572: $this->fclose( $fp );
    Line 789: function fclose( $fp ) {
    Line 794: return fclose( $fp );
    fopen was found in the file wordpress-importer.php
    Line 400: $out_fp = fopen( $file_path, 'w' );
    fwrite was found in the file wordpress-importer.php
    Line 405: fwrite( $out_fp, wp_remote_retrieve_body( $response ) );
    fclose was found in the file wordpress-importer.php
    Line 406: fclose( $out_fp );
    file_get_contents was found in the file vc-shortcode-autoloader.php
    Line 82: $contents = file_get_contents( $file );
    Line 113: $contents = file_get_contents( $file );
    file_get_contents was found in the file vc-shortcode-autoloader.php
    Line 82: $contents = file_get_contents( $file );
    Line 113: $contents = file_get_contents( $file );
    file_put_contents was found in the file vc-shortcode-autoloader.php
    Line 261: return (bool) file_put_contents( $target, $code );
    file_get_contents was found in the file class-ishyoboy-widget-data.php
    Line 8: $json_data = file_get_contents( $import_file );
    Line 365: $json_data = file_get_contents( $import_file );
    Line 408: $file_contents = file_get_contents( $widget_settings['file'] );
    file_get_contents was found in the file class-ishyoboy-widget-data.php
    Line 8: $json_data = file_get_contents( $import_file );
    Line 365: $json_data = file_get_contents( $import_file );
    Line 408: $file_contents = file_get_contents( $widget_settings['file'] );
    file_get_contents was found in the file class-ishyoboy-widget-data.php
    Line 8: $json_data = file_get_contents( $import_file );
    Line 365: $json_data = file_get_contents( $import_file );
    Line 408: $file_contents = file_get_contents( $widget_settings['file'] );
    file_get_contents was found in the file parsers.php
    Line 69: $success = $dom->loadXML( file_get_contents( $file ) );
    Line 274: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {
    file_get_contents was found in the file parsers.php
    Line 69: $success = $dom->loadXML( file_get_contents( $file ) );
    Line 274: if ( ! xml_parse( $xml, file_get_contents( $file ), true ) ) {
    fopen was found in the file parsers.php
    Line 422: $fp = $this->fopen( $file, 'r' );
    Line 648: function fopen( $filename, $mode = 'r' ) {
    Line 651: return fopen( $filename, $mode );
    fclose was found in the file parsers.php
    Line 471: $this->fclose($fp);
    Line 666: function fclose( $fp ) {
    Line 669: return fclose( $fp );
    fopen was found in the file parsers.php
    Line 422: $fp = $this->fopen( $file, 'r' );
    Line 648: function fopen( $filename, $mode = 'r' ) {
    Line 651: return fopen( $filename, $mode );
    fopen was found in the file parsers.php
    Line 422: $fp = $this->fopen( $file, 'r' );
    Line 648: function fopen( $filename, $mode = 'r' ) {
    Line 651: return fopen( $filename, $mode );
    fclose was found in the file parsers.php
    Line 471: $this->fclose($fp);
    Line 666: function fclose( $fp ) {
    Line 669: return fclose( $fp );
    fclose was found in the file parsers.php
    Line 471: $this->fclose($fp);
    Line 666: function fclose( $fp ) {
    Line 669: return fclose( $fp );
  6. Admin menu : Themes should use add_theme_page() for adding admin pages. File welcome-screen.php :
    Line 38: $page = add_submenu_page( VC_PAGE_MAIN_SLUG, __( 'About', 'js_composer' ), __( 'Abo
    File pages.php :
    Line 60: add_menu_page( __( 'WPBakery Page Builder', 'js_composer' ), __( 'WPBakery 
    Line 78: add_menu_page( __( 'WPBakery Page Builder', 'js_composer' ), __( 'WPBakery 
    File pages.php :
    Line 60: add_menu_page( __( 'WPBakery Page Builder', 'js_composer' ), __( 'WPBakery 
    Line 78: add_menu_page( __( 'WPBakery Page Builder', 'js_composer' ), __( 'WPBakery 
    File settings-tabs.php :
    Line 21: $page = add_submenu_page( VC_PAGE_MAIN_SLUG, $title, $title, 'manage_options', $slu
    File vc-grid-item-editor.php :
    Line 15: add_action( 'vc_menu_page_build', 'vc_gitem_add_submenu_page' );
    Line 259: function vc_gitem_add_submenu_page() {
    Line 262: add_submenu_page( VC_PAGE_MAIN_SLUG, $labels['name'], $labels['name'], 'edi
    File class-tgm-plugin-activation.php :
    Line 641: $this->page_hook = call_user_func( 'add_submenu_page', $args['parent_slug'], $args['page_title'], $args['menu_t
    File class-ishyoboy-widget-data.php :
    Line 43: $export_page = add_management_page( 'Widget Settings Export', 'Widget Settings Export', 'm
    Line 45: $import_page = add_management_page( 'Widget Settings Import', 'Widget Settings Import', 'm
    File class-ishyoboy-widget-data.php :
    Line 43: $export_page = add_management_page( 'Widget Settings Export', 'Widget Settings Export', 'm
    Line 45: $import_page = add_management_page( 'Widget Settings Import', 'Widget Settings Import', 'm
  7. Deprecated functions : screen_icon screen_icon found in file wordpress-importer.php. Deprecated since version 3.8.
    Line 1032: screen_icon();
  8. Deprecated functions : wp_get_http wp_get_http found in file wordpress-importer.php. Deprecated since version 4.4. Use WP_Http instead.
    Line 905: $headers = wp_get_http( $url, $upload['file'] );
  9. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was ishyoboy-boldial-assets.zip fontello-8deff5f6.zip fontello-a8056781.zip.
Warning
  1. core scripts deregistered : Core scripts deregistrationFound wp_deregister_script in wp_customize.php. Themes must not deregister core scripts.
    Line 17: wp_deregister_script( 'wpb_composer_front_js' );
  2. theme tags : Presence of bad theme tagsThe tag black has been deprecated, it must be removed from style.css header.The tag blue has been deprecated, it must be removed from style.css header.The tag brown has been deprecated, it must be removed from style.css header.The tag gray has been deprecated, it must be removed from style.css header.The tag green has been deprecated, it must be removed from style.css header.The tag orange has been deprecated, it must be removed from style.css header.The tag pink has been deprecated, it must be removed from style.css header.The tag purple has been deprecated, it must be removed from style.css header.The tag red has been deprecated, it must be removed from style.css header.The tag silver has been deprecated, it must be removed from style.css header.The tag tan has been deprecated, it must be removed from style.css header.The tag white has been deprecated, it must be removed from style.css header.The tag yellow has been deprecated, it must be removed from style.css header.The tag dark has been deprecated, it must be removed from style.css header.The tag light has been deprecated, it must be removed from style.css header.The tag flexible-width has been deprecated, it must be removed from style.css header.The tag photoblogging has been deprecated, it must be removed from style.css header.The tag seasonal has been deprecated, it must be removed from style.css header.
  3. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function __, with the arguments 'Yes' in file default_params.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file css_editor.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file class-vc-edit-form-fields.php.Found a translation function that is missing a text-domain. Function esc_attr_e, with the arguments '&wpb_vc_js_status=true' in file class-vc-navbar-frontend.php.Found a translation function that has an incorrect number of arguments. Function __, with the arguments 'custom.css could not be created. Cannot write custom css to "', ., 'js_composer' in file class-vc-settings.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file class-vc-settings.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file class-vc-license.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file class-vc-license.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Dismiss this notice.' in file class-vc-license.php.Found a translation function that has an incorrect number of arguments. Function __, with the arguments 'To receive automatic updates license activation is required. Please visit <a href="', , '" target="_blank">Settings</a> to activate your WPBakery Page Builder.' in file class-vc-updater.php.Found a translation function that has an incorrect number of arguments. Function __, with the arguments 'To receive automatic updates license activation is required. Please visit <a href="', , '" target="_blank">Settings</a> to activate your WPBakery Page Builder.', 'js_composer' in file class-vc-updater.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Visit %s to create your map (Step by step: 1) Find location 2) Click the cog symbol in the lower right corner and select "Share or embed map" 3) On modal window select "Embed map" 4) Copy iframe code and paste it).' in file shortcode-vc-gmaps.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file shortcode-vc-raw-js.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Meta' in file shortcode-vc-wp-meta.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Meta' in file shortcode-vc-wp-meta.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Archives' in file shortcode-vc-wp-archives.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Archives' in file shortcode-vc-wp-archives.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Recent Posts' in file shortcode-vc-wp-posts.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Recent Posts' in file shortcode-vc-wp-posts.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Tag Cloud' in file shortcode-vc-wp-tagcloud.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Recent Comments' in file shortcode-vc-wp-recentcomments.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Recent Comments' in file shortcode-vc-wp-recentcomments.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Categories' in file shortcode-vc-wp-categories.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Categories' in file shortcode-vc-wp-categories.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'RSS' in file shortcode-vc-wp-rss.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Links' in file shortcode-vc-wp-links.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Calendar' in file shortcode-vc-wp-calendar.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Search' in file shortcode-vc-wp-search.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Pages' in file shortcode-vc-wp-pages.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Pages' in file shortcode-vc-wp-pages.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Custom Menu' in file shortcode-vc-wp-custommenu.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Text' in file shortcode-vc-wp-text.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Author' in file functions.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'You must be <a href="%s">logged in</a> to post a comment.' in file functions.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Logged in as <a href="%1$s">%2$s</a>. <a href="%3$s" title="Log out of this account">Log out?</a>' in file functions.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'You may use these <abbr title="HyperText Markup Language">HTML</abbr> tags and attributes: %s' in file functions.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Import started...' in file class.options_machine.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Import Error!' in file class.options_machine.php.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are ishyoboy, js_composer, ., , woocommerce, wordpress-importer, tgmpa, ish_sc_plugin.
  4. Plugin territory : Plugin territory functionalitiesThe theme uses the register_post_type() function, which is plugin-territory functionality.The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
  5. Deprecated functions : screen_iconscreen_icon found in file wordpress-importer.php. Deprecated since version 3.8.
    Line 1032: screen_icon();
  6. Editor style : Presence of editor styleNo reference to add_editor_style() was found in the theme. It is recommended that the theme implements editor styling, so as to make the editor content match the resulting post output in the theme, for a better user experience.
  7. I18N implementation : Proper use of _e(Possible variable $post found in translation function in class-vc-navbar-frontend.php. Translation function calls should not contain PHP variables.
    Line 115: <button data-url='<?php esc_attr_e( get_edit_post_link( $post->ID ) . '&wpb_vc_js_status=true' ) ?>'
  8. I18N implementation : Proper use of ___all(Possible variable $style found in translation function in css_editor.php. Translation function calls should not contain PHP variables.
    Line 176: $output .= '<option value='' . $style . ''>' . __( ucfirst( $style ), 'js_composer' ) . '</option>';
    Possible variable $this found in translation function in class-vc-edit-form-fields.php. Translation function calls should not contain PHP variables.
    Line 221: $output .= '<div class='' . implode( ' ', $editor_css_classes ) . '' data-title='' . htmlspecialchars( __( 'Edit', 'js_composer' ) . ' ' . __( $this->setting( 'name' ), 'js_composer' ) ) . ''>';
    Possible variable $filename found in translation function in class-vc-settings.php. Translation function calls should not contain PHP variables.
    Line 906: add_settings_error( self::$field_prefix . 'custom_css', $wp_filesystem->errors->get_error_code(), __( 'custom.css could not be created. Cannot write custom css to '' . $file
    Possible variable $js_composer_upload_dir found in translation function in class-vc-settings.php. Translation function calls should not contain PHP variables.
    Line 929: add_settings_error( self::$field_prefix . $option, $wp_filesystem->errors->get_error_code(), __( sprintf( '%s could not be created. Not available to create js_composer 
    Possible variable $response found in translation function in class-vc-license.php. Translation function calls should not contain PHP variables.
    Line 148: $this->showError( __( sprintf( '%s. Please try again.', $response->get_error_message() ), 'js
    Possible variable $response found in translation function in class-vc-license.php. Translation function calls should not contain PHP variables.
    Line 154: $this->showError( __( sprintf( 'Server did not respond with OK: %s', $response['response']['c
    Possible variable $url found in translation function in class-vc-updater.php. Translation function calls should not contain PHP variables.
    Line 130: return new WP_Error( 'no_credentials', __( 'To receive automatic updates license activation is required. Please vi
  9. I18N implementation : Proper use of esc_attr_e(Possible variable $post found in translation function in class-vc-navbar-frontend.php. Translation function calls should not contain PHP variables.
    Line 115: <button data-url='<?php esc_attr_e( get_edit_post_link( $post->ID ) . '&wpb_vc_js_status=true' ) ?>
  10. CSS files : Presence of text domainText Domain: is missing from your style.css header.
  11. Screenshot : Screenshot fileScreenshot size is 880x660px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  4. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  5. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  6. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  7. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  8. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  9. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : helpers_factory.php
    Line 417: require_once( ABSPATH . '/wp-admin/includes/file.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : helpers.php
    Line 744: require_once 'class-vc-color-helper.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-frontend-editor.php
    Line 571: require( ABSPATH . WPINC . '/class-wp-editor.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-settings.php
    Line 816: require_once( ABSPATH . 'wp-admin/includes/template.php' );
    Line 818: require_once( ABSPATH . 'wp-admin/includes/file.php' );
    Line 971: require_once( ABSPATH . '/wp-admin/includes/file.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcodes.php
    Line 473: include( $this->html_template );
    Line 1304: require_once( $file );
    Line 1341: require_once( $file );
    Line 1443: require_once( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-vendor-woocommerce.php
    Line 1524: include_once( WC()->plugin_path() . '/includes/wc-template-functions.php' )
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-role-access.php
    Line 25: require_once( ABSPATH . 'wp-admin/includes/user.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vc_ui-template-preview.tpl.php
    Line 30: require_once( ABSPATH . 'wp-admin/admin-header.php' );
    Line 81: require_once( ABSPATH . 'wp-admin/admin-footer.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : frontend_editor.tpl.php
    Line 19: require_once( $editor->adminFile( 'admin-header.php' ) );
    Line 121: require_once( $editor->adminFile( 'admin-footer.php' ) ); ?>
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vc_ui-template-preview.tpl.php
    Line 36: require_once( ABSPATH . 'wp-admin/admin-header.php' );
    Line 127: require_once( ABSPATH . 'wp-admin/admin-footer.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : revslider.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : layerslider.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : gravity_forms.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ninja_forms.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : acf.php
    Line 23: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : mqtranslate.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : yoast_seo.php
    Line 19: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : cf7.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : woocommerce.php
    Line 29: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qtranslate.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vc-shortcode-autoloader.php
    Line 64: require_once( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-media-grid.php
    Line 6: require_once( 'class-vc-grids-common.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-masonry-grid.php
    Line 6: require_once( 'class-vc-grids-common.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-basic-grid.php
    Line 6: require_once( 'class-vc-grids-common.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-grids-common.php
    Line 6: require_once 'vc-grids-functions.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-masonry-media-grid.php
    Line 6: require_once( 'class-vc-grids-common.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-icon.php
    Line 6: require_once 'vc-icon-element.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-text-separator.php
    Line 6: require_once 'vc-icon-element.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : config_as_plugin.php
    Line 7: require_once( locate_template( 'assets/framework/wp/pagebuilder/ish_config/
    Line 38: require_once( locate_template( 'wpbakery/js_composer/js_composer.php' ) );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : init.php
    Line 3: require_once( locate_template( 'assets/framework/wp/options/custom-function
    Line 4: require_once( locate_template( 'assets/framework/wp/options/init-admin.php'
    Line 5: // require_once( locate_template( 'assets/framework/wp/widgets/widgets.php' ) 
    Line 6: require_once( locate_template( 'assets/framework/wp/posts/ishyo-meta-box.ph
    Line 9: require_once( locate_template( 'assets/framework/wp/posts/custom-meta-boxes
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : init-admin.php
    Line 39: include( IYB_FRAMEWORK_DIR . '/css/revolution-styles.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : custom-functions.php
    Line 324: require_once( $skin );
    Line 411: require( locate_template( 'assets/framework/wp/dynamic_css/dynamic_css.php'
    Line 463: require( locate_template( 'assets/framework/wp/dynamic_css/dynamic_css.php'
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : config.php
    Line 8: include_once( ABSPATH .'wp-admin/includes/plugin.php' );
    Line 41: include_once( IYB_FRAMEWORK_DIR . '/wp/importer/ishyoboy-wp-import.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ishyo-meta-box.php
    Line 67: 
    Line 97: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : dynamic_css.php
    Line 8: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_font
    Line 9: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_colo
    Line 12: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_colo
    Line 15: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_colo
    Line 16: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_patt
    Line 17: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_resp
    Line 18: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_misc
    Line 20: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_wooc
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ajax.php
    Line 14: require_once( locate_template( 'assets/framework/wp/importer/config.php' ) 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : index.php
    Line 128: require_once ( ADMIN_PATH . 'functions/functions.load.php' );
    Line 129: require_once ( ADMIN_PATH . 'classes/class.options_machine.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions.load.php
    Line 10: require_once( ADMIN_PATH . 'functions/functions.php' );
    Line 11: require_once( ADMIN_PATH . 'functions/functions.filters.php' );
    Line 12: require_once( ADMIN_PATH . 'functions/functions.interface.php' );
    Line 13: require_once( ADMIN_PATH . 'functions/functions.options.php' );
    Line 14: require_once( ADMIN_PATH . 'functions/functions.admin.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions.interface.php
    Line 76: include_once( ADMIN_PATH . 'front-end/options.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : wp-cron.php
    Line 26: require_once('./wp-load.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.

This is a ThemeForest theme. Since Themeforest items are all checked by a human before they appear on their website, ThemeForest verification rules are more permissive than themecheck's and can give a better verification score ( Themeforest requirements ).

13
  • THEME TYPEWordPress theme 4.9.4
  • FILE NAMEboldial.zip
  • FILE SIZE11427448 bytes
  • MD54c662f8dd6c4aedfd687ed12b66c74a1
  • SHA1b536fd83a6da8306b887b30cf92cea7704dcc604
  • LICENSEGNU GPL 2
  • FILES INCLUDEDCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • THEMEFOREST PAGEhttps://themeforest.net/item/boldial-wp-flat-creative-theme-with-3d-portfolio/7771632 ($59)
  • VERSION2.8
  • AUTHOR URI
  • TAGSblack, blue, brown, gray, green, orange, pink, purple, red, silver, tan, white, yellow, dark, light, one-column, two-columns, three-columns, four-columns, right-sidebar, flexible-width, custom-background, custom-colors, custom-header, custom-menu, editor-style, featured-image-header, featured-images, full-width-template, microformats, post-formats, theme-options, threaded-comments, translation-ready, holiday, photoblogging, seasonal
  • CREATION DATE2018-02-13
  • LAST FILE UPDATE2018-02-13
  • LAST VALIDATION2018-02-13 07:32
  • OTHER VERSIONS

    2.1 : 0%

Critical alerts
  1. Title : Title No reference to add_theme_support( "title-tag" ) was found in the theme.The theme needs to have <title> tags, ideally in the header.php file.The theme needs to have a call to wp_title(), ideally in the header.php file.The <title> tags can only contain a call to wp_title(). Use the wp_title filter to modify the output.
  2. Deprecated functions : screen_icon screen_icon found in file wordpress-importer.php. Deprecated since version 3.8.
    Line 1032: screen_icon();
  3. Deprecated functions : wp_get_http wp_get_http found in file wordpress-importer.php. Deprecated since version 4.4. Use WP_Http instead.
    Line 905: $headers = wp_get_http( $url, $upload['file'] );
  4. Included plugins : Zip file found Plugins are not allowed in themes. The zip file found was ishyoboy-boldial-assets.zip fontello-8deff5f6.zip fontello-a8056781.zip.
Warning
  1. core scripts deregistered : Core scripts deregistrationFound wp_deregister_script in wp_customize.php. Themes must not deregister core scripts.
    Line 17: wp_deregister_script( 'wpb_composer_front_js' );
  2. theme tags : Presence of bad theme tagsThe tag black has been deprecated, it must be removed from style.css header.The tag blue has been deprecated, it must be removed from style.css header.The tag brown has been deprecated, it must be removed from style.css header.The tag gray has been deprecated, it must be removed from style.css header.The tag green has been deprecated, it must be removed from style.css header.The tag orange has been deprecated, it must be removed from style.css header.The tag pink has been deprecated, it must be removed from style.css header.The tag purple has been deprecated, it must be removed from style.css header.The tag red has been deprecated, it must be removed from style.css header.The tag silver has been deprecated, it must be removed from style.css header.The tag tan has been deprecated, it must be removed from style.css header.The tag white has been deprecated, it must be removed from style.css header.The tag yellow has been deprecated, it must be removed from style.css header.The tag dark has been deprecated, it must be removed from style.css header.The tag light has been deprecated, it must be removed from style.css header.The tag flexible-width has been deprecated, it must be removed from style.css header.The tag photoblogging has been deprecated, it must be removed from style.css header.The tag seasonal has been deprecated, it must be removed from style.css header.
  3. Text domain : Incorrect use of translation functions.Found a translation function that is missing a text-domain. Function __, with the arguments 'Yes' in file default_params.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file css_editor.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file class-vc-edit-form-fields.php.Found a translation function that is missing a text-domain. Function esc_attr_e, with the arguments '&wpb_vc_js_status=true' in file class-vc-navbar-frontend.php.Found a translation function that has an incorrect number of arguments. Function __, with the arguments 'custom.css could not be created. Cannot write custom css to "', ., 'js_composer' in file class-vc-settings.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file class-vc-settings.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file class-vc-license.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file class-vc-license.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Dismiss this notice.' in file class-vc-license.php.Found a translation function that has an incorrect number of arguments. Function __, with the arguments 'To receive automatic updates license activation is required. Please visit <a href="', , '" target="_blank">Settings</a> to activate your WPBakery Page Builder.' in file class-vc-updater.php.Found a translation function that has an incorrect number of arguments. Function __, with the arguments 'To receive automatic updates license activation is required. Please visit <a href="', , '" target="_blank">Settings</a> to activate your WPBakery Page Builder.', 'js_composer' in file class-vc-updater.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Visit %s to create your map (Step by step: 1) Find location 2) Click the cog symbol in the lower right corner and select "Share or embed map" 3) On modal window select "Embed map" 4) Copy iframe code and paste it).' in file shortcode-vc-gmaps.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'js_composer' in file shortcode-vc-raw-js.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Meta' in file shortcode-vc-wp-meta.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Meta' in file shortcode-vc-wp-meta.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Archives' in file shortcode-vc-wp-archives.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Archives' in file shortcode-vc-wp-archives.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Recent Posts' in file shortcode-vc-wp-posts.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Recent Posts' in file shortcode-vc-wp-posts.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Tag Cloud' in file shortcode-vc-wp-tagcloud.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Recent Comments' in file shortcode-vc-wp-recentcomments.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Recent Comments' in file shortcode-vc-wp-recentcomments.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Categories' in file shortcode-vc-wp-categories.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Categories' in file shortcode-vc-wp-categories.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'RSS' in file shortcode-vc-wp-rss.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Links' in file shortcode-vc-wp-links.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Calendar' in file shortcode-vc-wp-calendar.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Search' in file shortcode-vc-wp-search.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Pages' in file shortcode-vc-wp-pages.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Pages' in file shortcode-vc-wp-pages.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Custom Menu' in file shortcode-vc-wp-custommenu.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Text' in file shortcode-vc-wp-text.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Author' in file functions.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'You must be <a href="%s">logged in</a> to post a comment.' in file functions.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Logged in as <a href="%1$s">%2$s</a>. <a href="%3$s" title="Log out of this account">Log out?</a>' in file functions.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'You may use these <abbr title="HyperText Markup Language">HTML</abbr> tags and attributes: %s' in file functions.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Import started...' in file class.options_machine.php.Found a translation function that is missing a text-domain. Function __, with the arguments 'Import Error!' in file class.options_machine.php.More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs. The domains found are ishyoboy, js_composer, ., , woocommerce, wordpress-importer, tgmpa, ish_sc_plugin.
  4. Plugin territory : Plugin territory functionalitiesThe theme uses the register_post_type() function, which is plugin-territory functionality.The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
  5. Deprecated functions : screen_iconscreen_icon found in file wordpress-importer.php. Deprecated since version 3.8.
    Line 1032: screen_icon();
  6. CSS files : Presence of text domainText Domain: is missing from your style.css header.
  7. Screenshot : Screenshot fileScreenshot size is 880x660px. Screenshot size should be 1200x900, to account for HiDPI displays. Any 4:3 image size is acceptable, but 1200x900 is preferred.Bad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  4. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  5. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  6. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  7. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  8. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  9. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : helpers_factory.php
    Line 417: require_once( ABSPATH . '/wp-admin/includes/file.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : helpers.php
    Line 744: require_once 'class-vc-color-helper.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-frontend-editor.php
    Line 571: require( ABSPATH . WPINC . '/class-wp-editor.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-settings.php
    Line 816: require_once( ABSPATH . 'wp-admin/includes/template.php' );
    Line 818: require_once( ABSPATH . 'wp-admin/includes/file.php' );
    Line 971: require_once( ABSPATH . '/wp-admin/includes/file.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcodes.php
    Line 473: include( $this->html_template );
    Line 1304: require_once( $file );
    Line 1341: require_once( $file );
    Line 1443: require_once( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-vendor-woocommerce.php
    Line 1524: include_once( WC()->plugin_path() . '/includes/wc-template-functions.php' )
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-role-access.php
    Line 25: require_once( ABSPATH . 'wp-admin/includes/user.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vc_ui-template-preview.tpl.php
    Line 30: require_once( ABSPATH . 'wp-admin/admin-header.php' );
    Line 81: require_once( ABSPATH . 'wp-admin/admin-footer.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : frontend_editor.tpl.php
    Line 19: require_once( $editor->adminFile( 'admin-header.php' ) );
    Line 121: require_once( $editor->adminFile( 'admin-footer.php' ) ); ?>
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vc_ui-template-preview.tpl.php
    Line 36: require_once( ABSPATH . 'wp-admin/admin-header.php' );
    Line 127: require_once( ABSPATH . 'wp-admin/admin-footer.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : revslider.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : layerslider.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : gravity_forms.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ninja_forms.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : acf.php
    Line 23: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : mqtranslate.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : yoast_seo.php
    Line 19: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : cf7.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : woocommerce.php
    Line 29: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : qtranslate.php
    Line 17: include_once( ABSPATH . 'wp-admin/includes/plugin.php' ); // Require plugin
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : vc-shortcode-autoloader.php
    Line 64: require_once( $file );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-media-grid.php
    Line 6: require_once( 'class-vc-grids-common.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-masonry-grid.php
    Line 6: require_once( 'class-vc-grids-common.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-basic-grid.php
    Line 6: require_once( 'class-vc-grids-common.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : class-vc-grids-common.php
    Line 6: require_once 'vc-grids-functions.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-masonry-media-grid.php
    Line 6: require_once( 'class-vc-grids-common.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-icon.php
    Line 6: require_once 'vc-icon-element.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : shortcode-vc-text-separator.php
    Line 6: require_once 'vc-icon-element.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : config_as_plugin.php
    Line 7: require_once( locate_template( 'assets/framework/wp/pagebuilder/ish_config/
    Line 38: require_once( locate_template( 'wpbakery/js_composer/js_composer.php' ) );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : init.php
    Line 3: require_once( locate_template( 'assets/framework/wp/options/custom-function
    Line 4: require_once( locate_template( 'assets/framework/wp/options/init-admin.php'
    Line 5: // require_once( locate_template( 'assets/framework/wp/widgets/widgets.php' ) 
    Line 6: require_once( locate_template( 'assets/framework/wp/posts/ishyo-meta-box.ph
    Line 9: require_once( locate_template( 'assets/framework/wp/posts/custom-meta-boxes
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : init-admin.php
    Line 39: include( IYB_FRAMEWORK_DIR . '/css/revolution-styles.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : custom-functions.php
    Line 324: require_once( $skin );
    Line 411: require( locate_template( 'assets/framework/wp/dynamic_css/dynamic_css.php'
    Line 463: require( locate_template( 'assets/framework/wp/dynamic_css/dynamic_css.php'
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : config.php
    Line 8: include_once( ABSPATH .'wp-admin/includes/plugin.php' );
    Line 41: include_once( IYB_FRAMEWORK_DIR . '/wp/importer/ishyoboy-wp-import.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ishyo-meta-box.php
    Line 67: 
    Line 97: 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : dynamic_css.php
    Line 8: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_font
    Line 9: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_colo
    Line 12: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_colo
    Line 15: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_colo
    Line 16: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_patt
    Line 17: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_resp
    Line 18: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_misc
    Line 20: include( locate_template( 'assets/framework/wp/dynamic_css/inc/dynamic_wooc
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : ajax.php
    Line 14: require_once( locate_template( 'assets/framework/wp/importer/config.php' ) 
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : index.php
    Line 128: require_once ( ADMIN_PATH . 'functions/functions.load.php' );
    Line 129: require_once ( ADMIN_PATH . 'classes/class.options_machine.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions.load.php
    Line 10: require_once( ADMIN_PATH . 'functions/functions.php' );
    Line 11: require_once( ADMIN_PATH . 'functions/functions.filters.php' );
    Line 12: require_once( ADMIN_PATH . 'functions/functions.interface.php' );
    Line 13: require_once( ADMIN_PATH . 'functions/functions.options.php' );
    Line 14: require_once( ADMIN_PATH . 'functions/functions.admin.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : functions.interface.php
    Line 76: include_once( ADMIN_PATH . 'front-end/options.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : wp-cron.php
    Line 26: require_once('./wp-load.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes