78
Validation results

Best Magazine

Free WordPress 4.9.8 theme

Best Magazine

Free WordPress 4.9.8 theme
78
    Error 8 : Undefined index: slug
    In /home/www/themecheck/themecheck/controllers/controller_results.php line 772
  • THEME TYPEWordPress theme 4.9.8
  • FILE NAMEbest-magazine.1.1.19.zip
  • FILE SIZE3148961 bytes
  • MD5840b7cd6badd3fa09a6727a848d1b1fe
  • SHA1ea1049ea8750d7ac0170e781ecdd198403a82775
  • LICENSEGNU GPL 3
  • FILES INCLUDEDCSS, PHP, Bitmap images
  • THEME URIhttps://web-dorado.com/wordpress-themes/best-magazine.html
  • VERSION1.1.19
  • AUTHOR URI
  • TAGSblack, blue, brown, gray, green, orange, pink, purple, red, silver, tan, white, yellow, dark, light, custom-menu, custom-header, custom-background, featured-images, custom-colors, flexible-header, full-width-template, one-column, two-columns, three-columns
  • CREATION DATE2016-07-07
  • LAST FILE UPDATE2017-03-05
  • LAST VALIDATION2017-03-05 22:08
  • OTHER VERSIONS

    2.1.23 : 55%

    1.1.6 : 97%

    1.1.23 : 97%

Error 8 : Undefined variable: cms
In /home/www/themecheck/themecheck/controllers/controller_results.php line 818
Critical alerts
  1. Admin menu : Themes should use add_theme_page() for adding admin pages. File class-tgm-plugin-activation.php :
    Ligne646: $this->page_hook = call_user_func( 'add_submenu_page', $args['parent_slug'], $args['page_title'], $args['menu_t
Warning
  1. theme tags : Presence of bad theme tagsThe tag black has been deprecated, it must be removed from style.css header.The tag blue has been deprecated, it must be removed from style.css header.The tag brown has been deprecated, it must be removed from style.css header.The tag gray has been deprecated, it must be removed from style.css header.The tag green has been deprecated, it must be removed from style.css header.The tag orange has been deprecated, it must be removed from style.css header.The tag pink has been deprecated, it must be removed from style.css header.The tag purple has been deprecated, it must be removed from style.css header.The tag red has been deprecated, it must be removed from style.css header.The tag silver has been deprecated, it must be removed from style.css header.The tag tan has been deprecated, it must be removed from style.css header.The tag white has been deprecated, it must be removed from style.css header.The tag yellow has been deprecated, it must be removed from style.css header.The tag dark has been deprecated, it must be removed from style.css header.The tag light has been deprecated, it must be removed from style.css header.The tag responsive-layout has been deprecated, it must be removed from style.css header.
  2. Screenshot : Screenshot fileBad screenshot file extension ! File screenshot.png is not an actual JPG file. Detected type was : "image/png".
Tip-off
  1. Optional files : Presence of rtl stylesheet rtl.cssThis theme does not contain optional file rtl.php.
  2. Optional files : Presence of front page template file front-page.phpThis theme does not contain optional file front-page.php.
  3. Optional files : Presence of category template file category.phpThis theme does not contain optional file category.php.
  4. Optional files : Presence of tag template file tag.phpThis theme does not contain optional file tag.php.
  5. Optional files : Presence of term template file taxonomy.phpThis theme does not contain optional file taxonomy.php.
  6. Optional files : Presence of author template file author.phpThis theme does not contain optional file author.php.
  7. Optional files : Presence of date/time template file date.phpThis theme does not contain optional file date.php.
  8. Optional files : Presence of attachment template file attachment.phpThis theme does not contain optional file attachment.php.
  9. Optional files : Presence of image template file image.phpThis theme does not contain optional file image.php.
  10. Use of includes : Use of include or requireThe theme appears to use include or require : customizer.php
    Ligne118: require_once('WDWT_control_classes.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : index.php
    Ligne8: require_once('admin/WDWT_admin_controller.php');
    Ligne10: require_once( 'lib/WDWT_input.php' );  
    Ligne12: require_once( 'lib/WDWT_output.php' );
    Ligne14: require_once('customizer/customizer.php');
    Ligne18: include_once('notices/WDWT_notices.php');
    Ligne24: require_once('admin/WDWT_admin_cpanel.php');
    Ligne26: require_once('admin/plugins.php'); 
    Ligne28: require_once('meta/meta.php');
    Ligne33: require_once('front/frontend_params_output.php');
    Ligne34: require_once('front/frontend_functions.php');
    Ligne41: require_once( 'widgets/widgets.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : frontend_functions.php
    Ligne4: require_once( 'WDWT_front_functions.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : frontend_params_output.php
    Ligne4: require_once('WDWT_front_params_output.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : WDWT_lightbox.php
    Ligne89: require_once('frontend_params_output.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : widgets.php
    Ligne6: require_once( 'widget-advert.php' );
    Ligne10: require_once( 'widget-adsens.php' );
    Ligne13: require_once( 'Spider_Random_Post.php' );
    Ligne16: require_once( 'widget-category.php' );
    Ligne19: require_once( 'widget-events-category.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : WDWT_input.php
    Ligne127: require_once( 'WDWT_kses.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : WDWT_output.php
    Ligne5: require_once( 'WDWT_admin_view.php' );
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : plugins.php
    Ligne23: require_once 'class-tgm-plugin-activation.php';
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : WDWT_admin_controller.php
    Ligne7: require_once( 'layout_page.php' );
    Ligne9: require_once( 'general_settings_page.php' );
    Ligne11: require_once( 'home_page.php' );
    Ligne13: require_once( 'typography_page.php' );
    Ligne15: require_once( 'slider_page.php' );
    Ligne18: require_once( 'licensing.php' );
    Ligne21: +require_once( 'lightbox_page.php' );
    Ligne61: require_once('updater.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : updater.php
    Ligne2: require_once ('WDWT_updater.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : meta_layout_controller.php
    Ligne7: require_once('meta_layout_model.php');
    Ligne8: require_once('meta_layout_view.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
    The theme appears to use include or require : meta.php
    Ligne13: require_once('WDWT_meta.php');
    Ligne22: require_once('WDWT_meta_model_section.php');
    Ligne23: require_once ('WDWT_meta_controller_section.php');
    Ligne26: require_once('meta_layout_controller.php');
    If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead. Otherwise, use include_once or require_once instead.
Other checked themes