50
Résultats de validation

X-Sport

X-Sport

WordPress 4.9.8 theme
50
  • TYPE DE THèMEThème WordPress %s 4.9.8
  • NOM DU FICHIERxsport.zip
  • TAILLE DU FICHIER21781525 octets
  • MD5a5877abd0ccc1381eff4c4891cb8f422
  • SHA16453a447777f2357062b2415c9bee1aebd7ab7f7
  • LICENCEAucun
  • FICHIERS INCLUSCSS, PHP, HTML, XML, Bitmap images, Adobe Illustrator
  • VERSION1.5.4
  • TAGSred , green , white
  • DATE DE CRéATION2018-10-07
  • DERNIèRE MISE à JOUR DU FICHIER2018-10-07
  • DERNIèRE VALIDATION2018-10-07 14:50
Alertes critiques
  1. Présence d'iframes : Les iframes sont parfois utilisées pour charger du contenu non désirés ou du code malicieux sur des sites tiers <iframe width="'.esc_attr($width).'" height="'.esc_attr($height).'" src="'.esc_url($src).'" class="vid iframe-'.esc_attr($site).'"> trouvé dans le fichier shortcode.php.
    Line 673: return '<div class='flex-video'><iframe width=''.esc_attr($width).'' height=''.esc_attr($height).'' src=''.
    <iframe width="885" height="487" src="http://www.youtube.com/embed/<?php echo esc_attr($my_array_of_vars['v']); ?> trouvé dans le fichier blog-video.php.
    Line 23: <iframe width='885' height='487' src='http://www.youtube.com/embed/<?php ec
  2. Inclusion de plugin : Présence de fichier zip Les plugins ne sont pas autorisés dans les thèmes. Le fichier zip mailchimp-for-wp.zip wordpress-importer.0.6.1.zip pixtheme-custom.zip the-events-calendar.zip regenerate-thumbnails.zip a été trouvé.
Attention
  1. tags du thème : Présence de tags inconnusLe tag red est obsolète, il ne doit pas figurer dans le header de style.css.Le tag green est obsolète, il ne doit pas figurer dans le header de style.css.Le tag white est obsolète, il ne doit pas figurer dans le header de style.css.
  2. Text domain : Utilisation incorrecte des fonctions de traduction.Mauvaus répertoire d'installation pour le thème. Le nom du répertoir doit correspondre au slug du thème. Le slug de ce thème ainsi que le text-domain est x-sport.
  3. Text domain : Utilisation incorrecte des fonctions de traduction.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'This theme requires the following plugin: %1$s.', 'This theme requires the following plugins: %1$s.' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'This theme recommends the following plugin: %1$s.', 'This theme recommends the following plugins: %1$s.' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Sorry, but you do not have the correct permissions to install the %s plugin. Contact the administrator of this site for help on getting the plugin installed.', 'Sorry, but you do not have the correct permissions to install the %s plugins. Contact the administrator of this site for help on getting the plugins installed.' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'The following required plugin is currently inactive: %1$s.', 'The following required plugins are currently inactive: %1$s.' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'The following recommended plugin is currently inactive: %1$s.', 'The following recommended plugins are currently inactive: %1$s.' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Sorry, but you do not have the correct permissions to activate the %s plugin. Contact the administrator of this site for help on getting the plugin activated.', 'Sorry, but you do not have the correct permissions to activate the %s plugins. Contact the administrator of this site for help on getting the plugins activated.' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'The following plugin needs to be updated to its latest version to ensure maximum compatibility with this theme: %1$s.', 'The following plugins need to be updated to their latest version to ensure maximum compatibility with this theme: %1$s.' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Sorry, but you do not have the correct permissions to update the %s plugin. Contact the administrator of this site for help on getting the plugin updated.', 'Sorry, but you do not have the correct permissions to update the %s plugins. Contact the administrator of this site for help on getting the plugins updated.' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Begin installing plugin', 'Begin installing plugins' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Begin activating plugin', 'Begin activating plugins' dans le fichier class-tgm-plugin-activation.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments 'BLOG' dans le fichier functions.php.Plusieurs text-domain sont utilisés dans le thème. Cela signifie que le thème n'est pas compatible avec les language packs de WordPress. Les domaines trouvés sont Straight, PixTheme, Butterfly, wp-pagenavi, arizona, PixAdmin, tgmpa, rwmb, uep, js_composer, PixShortcode, woocommerce, PixCustomize.
  4. Contextes de plugin : Fonctionnalités de pluginLe thème utilise la fonction add_shortcode(). L'utilisation des custom post-content shortcodes est du domaine des plugins.
  5. Uniformité des caractères de fin de ligne : Les fins de ligne DOS et UNIXLe fichier theme-settings.php contient un mélange de finde ligne \r\n and \n
  6. Barre d'admin cachée : Barre d'admin cachée dans CSSLes thèmes ne doivent pas cacher la barre d'admin. Détecté dans le fichier reports-print.css.
  7. Editor style : Présence de l'édition de styleAucune référence à add_editor_style() n'a été trouvée dans le thème. Il est recommandé que le thème implémente l'édition de style, de manière à faire correspondre le contenu de l'éditeur l'affichage dans le thème.
  8. Fichiers CSS : Présence de text domainLa déclaration Text Domain: manque dans le header du fichier style.css.
  9. Fichiers CSS : Présence de la classe .screen-reader-textLa class css .screen-reader-text est nécessaire dans le css du thème. Voir : le Codex pour un exemple d'implémentation.
  10. Screenshot : Copie d'écranLa taille du screenshot est 880x660px. La taille recommandée est 1200x900, pour prendre en compte les affichages HiDPI. Bien qu'une résolution de 1200x900 soit recommandée, toutes les images au format 4:3 sont acceptables.
Info
  1. Fichiers optionnels : Présence du fichierde style pour les écritures de droite vers la gauche rtl.cssCe thème ne contient pas le fichier optionnel rtl.php.
  2. Fichiers optionnels : Présence du fichier-template fron-*page.phpCe thème ne contient pas le fichier optionnel front-page.php.
  3. Fichiers optionnels : Présence du fichier-template de page d'accueil home.phpCe thème ne contient pas le fichier optionnel home.php.
  4. Fichiers optionnels : Présence du fichier-template de catégorie category.phpCe thème ne contient pas le fichier optionnel category.php.
  5. Fichiers optionnels : Présence du fichier-template des tags tag.phpCe thème ne contient pas le fichier optionnel tag.php.
  6. Fichiers optionnels : Présence du fichier-template author.phpCe thème ne contient pas le fichier optionnel author.php.
  7. Fichiers optionnels : Présence du fichier-template des pièces jointes attachment.phpCe thème ne contient pas le fichier optionnel attachment.php.
  8. Utilisation d'includes : Utilisation de include ou de de requireLe thème semble utiliser include ou require : scripts.php
    Line 4: require_once($adminPath . 'theme-settings.php');
    Line 5: require_once($adminPath . 'content-importer.php');
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : class-tgm-plugin-activation.php
    Line 1061: require_once( ABSPATH . 'wp-admin/includes/class-wp-list-table.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : modules.php
    Line 7: require_once ($panelPath . 'general-settings.php');
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : admin-panel.php
    Line 51: require_once (TEMPLATEPATH . '/library/admin/admin-panel/menu.php');
    Line 55: require_once (TEMPLATEPATH . '/library/admin/admin-panel/modules.php');
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : taxonomy-portfolio_category.php
    Line 163: <?php include(PixTheme_PLUGINS . '/wp-pagenavi.php' ); wp_pagenavi(); ?> 
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : loop.php
    Line 40: include(PixTheme_PLUGINS. '/wp-pagenavi.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : dynamic-styles.php
    Line 4: require_once( $parse_uri[0] . 'wp-load.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
Autre thèmes vérifiés