0
Résultats de validation

Hillter

Hillter

WordPress 4.9.8 theme
0
  • TYPE DE THèMEThème WordPress %s 4.9.8
  • NOM DU FICHIERhillter2.zip
  • TAILLE DU FICHIER17487520 octets
  • MD508dfd835af039d1401c89be8b564f114
  • SHA182fd3e8e5c1d6d1ed99f55b4cf41137c2fc0573e
  • LICENCEPropriétaire
  • FICHIERS INCLUSCSS, PHP, XML, Bitmap images, Adobe Illustrator
  • PAGE THEMEFORESThttps://themeforest.net/item/hillter-responsive-hotel-booking-for-wordpress/12727001 ($64)
  • URI DU THèME URIhttp://awethemes.com
  • VERSION2.0.8
  • URI DE L'AUTEUR
  • TAGStranslation-ready, threaded-comments, theme-options, sticky-post, post-formats, full-width-template, featured-images, custom-menu, custom-colors, custom-background, fluid-layout, fixed-layout, responsive-layout
  • DATE DE CRéATION2018-08-07
  • DERNIèRE MISE à JOUR DU FICHIER2018-08-07
  • DERNIèRE VALIDATION2018-08-07 19:55
  • AUTRES VERSIONS

    1.13.6 : 0%

    1.0 : 0%

Alertes critiques
  1. Failles de sécurité : Utilisation de base64_decode() base64_decode trouvé dans le fichier awe_video.php.
    Line 75: $content = urldecode( base64_decode( $atts['video'] ) );
  2. Présence d'iframes : Les iframes sont parfois utilisées pour charger du contenu non désirés ou du code malicieux sur des sites tiers <iframe class="embed-responsive-item" src="' . esc_url( $v['embed'] ) . '"> trouvé dans le fichier functions.php.
    Line 101: $video .= '<iframe class='embed-responsive-item' src='' . esc_url( $v['embed'] ) . ''>
    <iframe class="embed-responsive-item" src="<?php echo esc_url( $value['embed'] ); ?> trouvé dans le fichier class-awe-thumbnail.php.
    Line 310: <iframe class='embed-responsive-item' src='<?php echo esc_url( $value['embe
  3. Menu Admin : Les thèmes doivent utiliser add_theme_page () pour ajouter des pages admin. Fichier AWE-Framework.php :
    Line 283: //        add_menu_page( THEME_NAME, THEME_NAME, 'manage_options', 'AWE-Framework',ar
    Fichier AWE-Framework.php :
    Line 284: //        add_submenu_page( 'AWE-Framework', 'Tutorial & Support', 'Tutorial & Suppor
    Line 285: //        add_submenu_page('AWE-Framework', 'Modules', 'Modules', 'manage_options', '
    Fichier AWE-Framework.php :
    Line 284: //        add_submenu_page( 'AWE-Framework', 'Tutorial & Support', 'Tutorial & Suppor
    Line 285: //        add_submenu_page('AWE-Framework', 'Modules', 'Modules', 'manage_options', '
    Fichier class-tgm-plugin-activation.php :
    Line 580: $this->page_hook = call_user_func( 'add_{$type}_page', $args['parent_slug'], $args['page_title'], $args['menu_t
    Fichier user.php :
    Line 37: add_submenu_page( 'AWE-Framework', 'User Profile Settings', 'User Profile',
    Fichier update.php :
    Line 58: add_submenu_page( 'AWE-Framework', 'Update', 'Update', 'manage_options', 'A
    Fichier settings.php :
    Line 490: add_menu_page( THEME_NAME, THEME_NAME, 'manage_options', 'AWE-Framework', a
    Fichier settings.php :
    Line 494: add_submenu_page( 'AWE-Framework', 'Theme Settings', 'Theme Settings', 'man
    Fichier importer.php :
    Line 41: add_submenu_page( 'AWE-Framework', 'Import Demo Data', 'Import Demo Data', 
    Fichier security.php :
    Line 198: add_submenu_page( 'AWE-Framework', 'Security Settings', 'Security', 'manage
  4. Fonctions obsolètes : get_currentuserinfo get_currentuserinfo trouvé dans le fichier pluggable.min.php . Obsolète depuis la version de la 4.5. Il est prérable d'utiliser wp_get_current_user à la place.
    Line 6: get_currentuserinfo();
    Line 12: if ( !function_exists('get_currentuserinfo') ) :
    Line 26: function get_currentuserinfo() {
  5. Déclaration des "theme features" : Implémentation de add_theme_support() a été trouvé dans le fichier init.php alors que get_post_format ou has_post_format sont introuvables , and no use of formats in the CSS was detected
  6. Inclusion de plugin : Présence de fichier zip Les plugins ne sont pas autorisés dans les thèmes. Le fichier zip dummy-data.zip hillter-require.zip revslider.zip js_composer.zip a été trouvé.
Attention
  1. URIs particulières : Présence de tags inconnusTheme URI et Author URI ne doivent pas être identiques.
  2. tags du thème : Présence de tags inconnusLe tag fluid-layout est obsolète, il ne doit pas figurer dans le header de style.css.Le tag fixed-layout est obsolète, il ne doit pas figurer dans le header de style.css.Le tag responsive-layout est obsolète, il ne doit pas figurer dans le header de style.css.
  3. Text domain : Utilisation incorrecte des fonctions de traduction.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'This theme requires the following plugin: %1$s.', 'This theme requires the following plugins: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'This theme recommends the following plugin: %1$s.', 'This theme recommends the following plugins: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Sorry, but you do not have the correct permissions to install the %s plugin. Contact the administrator of this site for help on getting the plugin installed.', 'Sorry, but you do not have the correct permissions to install the %s plugins. Contact the administrator of this site for help on getting the plugins installed.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'The following required plugin is currently inactive: %1$s.', 'The following required plugins are currently inactive: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'The following recommended plugin is currently inactive: %1$s.', 'The following recommended plugins are currently inactive: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Sorry, but you do not have the correct permissions to activate the %s plugin. Contact the administrator of this site for help on getting the plugin activated.', 'Sorry, but you do not have the correct permissions to activate the %s plugins. Contact the administrator of this site for help on getting the plugins activated.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'The following plugin needs to be updated to its latest version to ensure maximum compatibility with this theme: %1$s.', 'The following plugins need to be updated to their latest version to ensure maximum compatibility with this theme: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Sorry, but you do not have the correct permissions to update the %s plugin. Contact the administrator of this site for help on getting the plugin updated.', 'Sorry, but you do not have the correct permissions to update the %s plugins. Contact the administrator of this site for help on getting the plugins updated.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Begin installing plugin', 'Begin installing plugins' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Begin activating plugin', 'Begin activating plugins' dans le fichier activation.php.Utilisation d'une fonction de traduction avec un nombre incorrect d'arguments. Fonction __, avec les arguments "Enter the API Key of your Account here.You can <a href=\"", asset/images/WordPress-Envato-Auto-Updates-01.png\>find your API Key here</a>, 'hillter' dans le fichier update_html.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Display Preload?" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Enable sticky menu?" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Custom color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Button color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Navigation Color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Navigation Text Color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Footer Color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Footer Text Color" dans le fichier settings_tpl.php.Utilisation d'une fonction de traduction avec un nombre incorrect d'arguments. Fonction __, avec les arguments 'Your URL login page: <a href="', class=awe-new-login-url>, 'hillter' dans le fichier security_tpl.php.Plusieurs text-domain sont utilisés dans le thème. Cela signifie que le thème n'est pas compatible avec les language packs de WordPress. Les domaines trouvés sont hillter, awebooking, tgmpa, envato, asset/images/WordPress-Envato-Auto-Updates-01.png\>find your API Key here</a>, /, class=awe-new-login-url>, js_composer, event2.
  4. Eléments custom : Présence d'une entête customAucune référence à custom header n'a été trouvée dans le thème.
  5. Eléments custom : Présence d'un fond customAucune référence à custom background n'a été trouvée dans le thème.
  6. Implémentation de l'internationalisation : Utilisation correcte de ___al(La variable $hide_login_url a été trouvée dans une fonction de traduction dans le fichier security_tpl.php . Les appels de fonctions de traduction ne doivent pas contenir de variables PHP.
    Line 44: $extra .= $this->generate_input(array('class'=>'input-border','placeholder'=>__('Change path login as you want. ex: /login','hillter'),'name'=>'security[slug-login]','value'=>$this->security_options['slug-login'],'desc'=>__('Your URL login page: <a href=''.esc_url(home_url('/'.$hide_login_url)).
    La variable $hide_login a été trouvée dans une fonction de traduction dans le fichier security_tpl.php . Les appels de fonctions de traduction ne doivent pas contenir de variables PHP.
    Line 47: $this->generate_section_html(false,__('Hide Login Page','hillter'),__('Hide wp-login.php (Note: You need to remember new address to login!','h
  7. Screenshot : Copie d'écranLa taille du screenshot est 880x660px. La taille recommandée est 1200x900, pour prendre en compte les affichages HiDPI. Bien qu'une résolution de 1200x900 soit recommandée, toutes les images au format 4:3 sont acceptables.Mauvaise extension de fichier screenshot ! Le fichier screenshot.png n'est pas un véritable fichier PNG. Le type détecté est : "image/jpeg".
Info
  1. Liens statiques : Présence de liens codés en durLien potentiellement codés en dur trouvé dans le fichier module_html.php.
    Line 55: <p class='md-copyright'>Designed and Developed by <a href='http://awethemes.com/'>AweThemes</a></p>
    Lien potentiellement codés en dur trouvé dans le fichier update_html.php.
    Line 59: <p class='md-copyright'>Designed and Developed by <a href='http://awethemes.com/'>AweThemes</a></p>
    Lien potentiellement codés en dur trouvé dans le fichier settings_tpl.php.
    Line 816: $desc       = '<p>' . __( 'Go to <a href='http://www.google.com/webfonts'>http://www.google.com/webfonts</a>, choose 
    Line 1207: <button class='md-button'><a target='_blank' href='http://awethemes.com/docs/hillter'>Document Online</a></button>
    Line 1231: <p class='md-copyright'>Designed and Developed by <a href='http://awethemes.com/'>AweThemes</a></p>
    Lien potentiellement codés en dur trouvé dans le fichier importer_tpl.php.
    Line 58: <a href='http://demo.awethemes.com' class='md-button <?php echo ($import!='restore')
    Lien potentiellement codés en dur trouvé dans le fichier header.php.
    Line 44: <a href='https://resultimes.com/'>Download WordPress Themes</a>, <a href='https://ww
  2. Fichiers optionnels : Présence du fichierde style pour les écritures de droite vers la gauche rtl.cssCe thème ne contient pas le fichier optionnel rtl.php.
  3. Fichiers optionnels : Présence du fichier-template fron-*page.phpCe thème ne contient pas le fichier optionnel front-page.php.
  4. Fichiers optionnels : Présence du fichier-template de page d'accueil home.phpCe thème ne contient pas le fichier optionnel home.php.
  5. Fichiers optionnels : Présence du fichier template de taxinomie taxonomy.phpCe thème ne contient pas le fichier optionnel taxonomy.php.
  6. Fichiers optionnels : Présence du fichier-template author.phpCe thème ne contient pas le fichier optionnel author.php.
  7. Fichiers optionnels : Présence de du fichier-template des dates et heures date.phpCe thème ne contient pas le fichier optionnel date.php.
  8. Fichiers optionnels : Présence du fichier-template des pièces jointes attachment.phpCe thème ne contient pas le fichier optionnel attachment.php.
  9. Fichiers optionnels : Présence du fichier-template des images image.phpCe thème ne contient pas le fichier optionnel image.php.
  10. Utilisation d'includes : Utilisation de include ou de de requireLe thème semble utiliser include ou require : AWE-Framework.php
    Line 13: include( AWE_ROOT_DIR . 'pluggable.min.php' );
    Line 45: include_once( AWE_ROOT_DIR . 'modules/theme/settings.php' );
    Line 64: include_once( AWE_ROOT_DIR . '/modules/activation/activation.php' );
    Line 69: include( AWE_ROOT_DIR . 'modules/seo/seo.php' );
    Line 75: include_once( AWE_ROOT_DIR . 'modules/security/security.php' );
    Line 82: include_once( AWE_ROOT_DIR . 'modules/widgets/widgets.php' );
    Line 88: include_once( AWE_ROOT_DIR . 'modules/user/user.php' );
    Line 93: // include_once( AWE_ROOT_DIR . '/modules/update/update.php' );
    Line 97: include_once( AWE_ROOT_DIR . '/modules/importer/importer.php' );
    Line 102: include_once( AWE_ROOT_DIR . 'modules/others/metabox.php' );
    Line 292: include( AWE_ROOT_DIR . 'module_html.php' );
    Line 299: include( AWE_ROOT_DIR . 'support_html.php' );
    Line 308: require_once( ABSPATH . '/wp-admin/includes/user.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : class-envato-wordpress-theme-upgrader.php
    Line 11: include_once( ABSPATH . 'wp-admin/includes/class-wp-upgrader.php' );
    Line 13: include_once( AWE_ROOT_DIR . 'lib/envato-wordpress-toolkit-library/class-en
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : class.ajax-processing.php
    Line 27: include($file);
    Line 41: include ( get_template_directory() .
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : activation.php
    Line 16: require_once (AWE_ROOT_DIR.'/lib/tgm-plugin-activation/class-tgm-plugin-act
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : widgets.php
    Line 11: // require_once( AWE_ROOT_DIR . '/lib/mailchimp/MailChimp.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : update.php
    Line 127: require_once( AWE_ROOT_DIR.'/lib/envato-wordpress-toolkit-library/class-env
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : settings.php
    Line 479: include( AWE_ROOT_DIR . '/modules/font/icons_tpl.php' );
    Line 819: require( $css_dir . $file_source );
    Line 1901: require_once( AWE_ROOT_DIR . '/lib/mailchimp/MailChimp.php' );
    Line 1920: require_once( AWE_ROOT_DIR . '/lib/mailchimp/MailChimp.php' );
    Line 1960: require_once( AWE_ROOT_DIR . '/lib/mailchimp/MailChimp.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : importer.php
    Line 92: require_once($class_wp_importer);
    Line 103: require_once($class_wp_import);
    Line 116: include_once( get_template_directory() . '/Framework/modules/importer/awe-i
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : security.php
    Line 392: //        include( $template );
    Line 426: require_once(ABSPATH . 'wp-includes/pluggable.php');
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : config.php
    Line 58: require_once($file);
    Line 67: require_once($file);
    Line 74: include_once( get_template_directory() . '/awe_shortcode/abstract-shortcode
    Line 82: require_once(STYLESHEETPATH . '/awe_shortcode/' . $locate_file );
    Line 84: require_once($file);
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : config-framework.php
    Line 221: 'slug' => 'hillter-require',
    Line 244: include( get_template_directory() . '/Framework/AWE-Framework.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : init.php
    Line 86: require_once( get_template_directory() . '/config/config-wpml.php');
    Line 87: require_once( get_template_directory() . '/config/config-framework.php');
    Line 88: require_once( get_template_directory() . '/config/config-footer.php');
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : init.php
    Line 12: require_once( AWE_THUMBNAIL_INC_DIR . 'class-awe-thumbnail.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.

Ceci est un thème distribué surThemeForest. Etant donné que tous les thèmes de Themeforest sont validés par un humain avant d'être mis en ligne, les règles de vérification de Themeforest sont plus permissives que celles de themecheck et peuvent donner un meilleur score de vérification ( Themeforest requirements ).

36
  • TYPE DE THèMEThème WordPress %s 4.9.8
  • NOM DU FICHIERhillter2.zip
  • TAILLE DU FICHIER17487520 octets
  • MD508dfd835af039d1401c89be8b564f114
  • SHA182fd3e8e5c1d6d1ed99f55b4cf41137c2fc0573e
  • LICENCEPropriétaire
  • FICHIERS INCLUSCSS, PHP, XML, Bitmap images, Adobe Illustrator
  • PAGE THEMEFORESThttps://themeforest.net/item/hillter-responsive-hotel-booking-for-wordpress/12727001 ($64)
  • URI DU THèME URIhttp://awethemes.com
  • VERSION2.0.8
  • URI DE L'AUTEUR
  • TAGStranslation-ready, threaded-comments, theme-options, sticky-post, post-formats, full-width-template, featured-images, custom-menu, custom-colors, custom-background, fluid-layout, fixed-layout, responsive-layout
  • DATE DE CRéATION2018-08-07
  • DERNIèRE MISE à JOUR DU FICHIER2018-08-07
  • DERNIèRE VALIDATION2018-08-07 19:55
  • AUTRES VERSIONS

    1.13.6 : 0%

    1.0 : 0%

Alertes critiques
  1. Fonctions obsolètes : get_currentuserinfo get_currentuserinfo trouvé dans le fichier pluggable.min.php . Obsolète depuis la version de la 4.5. Il est prérable d'utiliser wp_get_current_user à la place.
    Line 6: get_currentuserinfo();
    Line 12: if ( !function_exists('get_currentuserinfo') ) :
    Line 26: function get_currentuserinfo() {
  2. Déclaration des "theme features" : Implémentation de add_theme_support() a été trouvé dans le fichier init.php alors que get_post_format ou has_post_format sont introuvables , and no use of formats in the CSS was detected
  3. Inclusion de plugin : Présence de fichier zip Les plugins ne sont pas autorisés dans les thèmes. Le fichier zip dummy-data.zip hillter-require.zip revslider.zip js_composer.zip a été trouvé.
Attention
  1. URIs particulières : Présence de tags inconnusTheme URI et Author URI ne doivent pas être identiques.
  2. tags du thème : Présence de tags inconnusLe tag fluid-layout est obsolète, il ne doit pas figurer dans le header de style.css.Le tag fixed-layout est obsolète, il ne doit pas figurer dans le header de style.css.Le tag responsive-layout est obsolète, il ne doit pas figurer dans le header de style.css.
  3. Text domain : Utilisation incorrecte des fonctions de traduction.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'This theme requires the following plugin: %1$s.', 'This theme requires the following plugins: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'This theme recommends the following plugin: %1$s.', 'This theme recommends the following plugins: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Sorry, but you do not have the correct permissions to install the %s plugin. Contact the administrator of this site for help on getting the plugin installed.', 'Sorry, but you do not have the correct permissions to install the %s plugins. Contact the administrator of this site for help on getting the plugins installed.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'The following required plugin is currently inactive: %1$s.', 'The following required plugins are currently inactive: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'The following recommended plugin is currently inactive: %1$s.', 'The following recommended plugins are currently inactive: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Sorry, but you do not have the correct permissions to activate the %s plugin. Contact the administrator of this site for help on getting the plugin activated.', 'Sorry, but you do not have the correct permissions to activate the %s plugins. Contact the administrator of this site for help on getting the plugins activated.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'The following plugin needs to be updated to its latest version to ensure maximum compatibility with this theme: %1$s.', 'The following plugins need to be updated to their latest version to ensure maximum compatibility with this theme: %1$s.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Sorry, but you do not have the correct permissions to update the %s plugin. Contact the administrator of this site for help on getting the plugin updated.', 'Sorry, but you do not have the correct permissions to update the %s plugins. Contact the administrator of this site for help on getting the plugins updated.' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Begin installing plugin', 'Begin installing plugins' dans le fichier activation.php.Une fonction de traduction utilisée sans text-domain. Fonction _n_noop, avec les arguments 'Begin activating plugin', 'Begin activating plugins' dans le fichier activation.php.Utilisation d'une fonction de traduction avec un nombre incorrect d'arguments. Fonction __, avec les arguments "Enter the API Key of your Account here.You can <a href=\"", asset/images/WordPress-Envato-Auto-Updates-01.png\>find your API Key here</a>, 'hillter' dans le fichier update_html.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Display Preload?" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Enable sticky menu?" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Custom color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Button color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Navigation Color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Navigation Text Color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Footer Color" dans le fichier settings_tpl.php.Une fonction de traduction utilisée sans text-domain. Fonction __, avec les arguments "Footer Text Color" dans le fichier settings_tpl.php.Utilisation d'une fonction de traduction avec un nombre incorrect d'arguments. Fonction __, avec les arguments 'Your URL login page: <a href="', class=awe-new-login-url>, 'hillter' dans le fichier security_tpl.php.Plusieurs text-domain sont utilisés dans le thème. Cela signifie que le thème n'est pas compatible avec les language packs de WordPress. Les domaines trouvés sont hillter, awebooking, tgmpa, envato, asset/images/WordPress-Envato-Auto-Updates-01.png\>find your API Key here</a>, /, class=awe-new-login-url>, js_composer, event2.
  4. Screenshot : Copie d'écranLa taille du screenshot est 880x660px. La taille recommandée est 1200x900, pour prendre en compte les affichages HiDPI. Bien qu'une résolution de 1200x900 soit recommandée, toutes les images au format 4:3 sont acceptables.Mauvaise extension de fichier screenshot ! Le fichier screenshot.png n'est pas un véritable fichier PNG. Le type détecté est : "image/jpeg".
Info
  1. Liens statiques : Présence de liens codés en durLien potentiellement codés en dur trouvé dans le fichier module_html.php.
    Line 55: <p class='md-copyright'>Designed and Developed by <a href='http://awethemes.com/'>AweThemes</a></p>
    Lien potentiellement codés en dur trouvé dans le fichier update_html.php.
    Line 59: <p class='md-copyright'>Designed and Developed by <a href='http://awethemes.com/'>AweThemes</a></p>
    Lien potentiellement codés en dur trouvé dans le fichier settings_tpl.php.
    Line 816: $desc       = '<p>' . __( 'Go to <a href='http://www.google.com/webfonts'>http://www.google.com/webfonts</a>, choose 
    Line 1207: <button class='md-button'><a target='_blank' href='http://awethemes.com/docs/hillter'>Document Online</a></button>
    Line 1231: <p class='md-copyright'>Designed and Developed by <a href='http://awethemes.com/'>AweThemes</a></p>
    Lien potentiellement codés en dur trouvé dans le fichier importer_tpl.php.
    Line 58: <a href='http://demo.awethemes.com' class='md-button <?php echo ($import!='restore')
    Lien potentiellement codés en dur trouvé dans le fichier header.php.
    Line 44: <a href='https://resultimes.com/'>Download WordPress Themes</a>, <a href='https://ww
  2. Fichiers optionnels : Présence du fichierde style pour les écritures de droite vers la gauche rtl.cssCe thème ne contient pas le fichier optionnel rtl.php.
  3. Fichiers optionnels : Présence du fichier-template fron-*page.phpCe thème ne contient pas le fichier optionnel front-page.php.
  4. Fichiers optionnels : Présence du fichier-template de page d'accueil home.phpCe thème ne contient pas le fichier optionnel home.php.
  5. Fichiers optionnels : Présence du fichier template de taxinomie taxonomy.phpCe thème ne contient pas le fichier optionnel taxonomy.php.
  6. Fichiers optionnels : Présence du fichier-template author.phpCe thème ne contient pas le fichier optionnel author.php.
  7. Fichiers optionnels : Présence de du fichier-template des dates et heures date.phpCe thème ne contient pas le fichier optionnel date.php.
  8. Fichiers optionnels : Présence du fichier-template des pièces jointes attachment.phpCe thème ne contient pas le fichier optionnel attachment.php.
  9. Fichiers optionnels : Présence du fichier-template des images image.phpCe thème ne contient pas le fichier optionnel image.php.
  10. Utilisation d'includes : Utilisation de include ou de de requireLe thème semble utiliser include ou require : AWE-Framework.php
    Line 13: include( AWE_ROOT_DIR . 'pluggable.min.php' );
    Line 45: include_once( AWE_ROOT_DIR . 'modules/theme/settings.php' );
    Line 64: include_once( AWE_ROOT_DIR . '/modules/activation/activation.php' );
    Line 69: include( AWE_ROOT_DIR . 'modules/seo/seo.php' );
    Line 75: include_once( AWE_ROOT_DIR . 'modules/security/security.php' );
    Line 82: include_once( AWE_ROOT_DIR . 'modules/widgets/widgets.php' );
    Line 88: include_once( AWE_ROOT_DIR . 'modules/user/user.php' );
    Line 93: // include_once( AWE_ROOT_DIR . '/modules/update/update.php' );
    Line 97: include_once( AWE_ROOT_DIR . '/modules/importer/importer.php' );
    Line 102: include_once( AWE_ROOT_DIR . 'modules/others/metabox.php' );
    Line 292: include( AWE_ROOT_DIR . 'module_html.php' );
    Line 299: include( AWE_ROOT_DIR . 'support_html.php' );
    Line 308: require_once( ABSPATH . '/wp-admin/includes/user.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : class-envato-wordpress-theme-upgrader.php
    Line 11: include_once( ABSPATH . 'wp-admin/includes/class-wp-upgrader.php' );
    Line 13: include_once( AWE_ROOT_DIR . 'lib/envato-wordpress-toolkit-library/class-en
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : class.ajax-processing.php
    Line 27: include($file);
    Line 41: include ( get_template_directory() .
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : activation.php
    Line 16: require_once (AWE_ROOT_DIR.'/lib/tgm-plugin-activation/class-tgm-plugin-act
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : widgets.php
    Line 11: // require_once( AWE_ROOT_DIR . '/lib/mailchimp/MailChimp.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : update.php
    Line 127: require_once( AWE_ROOT_DIR.'/lib/envato-wordpress-toolkit-library/class-env
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : settings.php
    Line 479: include( AWE_ROOT_DIR . '/modules/font/icons_tpl.php' );
    Line 819: require( $css_dir . $file_source );
    Line 1901: require_once( AWE_ROOT_DIR . '/lib/mailchimp/MailChimp.php' );
    Line 1920: require_once( AWE_ROOT_DIR . '/lib/mailchimp/MailChimp.php' );
    Line 1960: require_once( AWE_ROOT_DIR . '/lib/mailchimp/MailChimp.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : importer.php
    Line 92: require_once($class_wp_importer);
    Line 103: require_once($class_wp_import);
    Line 116: include_once( get_template_directory() . '/Framework/modules/importer/awe-i
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : security.php
    Line 392: //        include( $template );
    Line 426: require_once(ABSPATH . 'wp-includes/pluggable.php');
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : config.php
    Line 58: require_once($file);
    Line 67: require_once($file);
    Line 74: include_once( get_template_directory() . '/awe_shortcode/abstract-shortcode
    Line 82: require_once(STYLESHEETPATH . '/awe_shortcode/' . $locate_file );
    Line 84: require_once($file);
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : config-framework.php
    Line 221: 'slug' => 'hillter-require',
    Line 244: include( get_template_directory() . '/Framework/AWE-Framework.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : init.php
    Line 86: require_once( get_template_directory() . '/config/config-wpml.php');
    Line 87: require_once( get_template_directory() . '/config/config-framework.php');
    Line 88: require_once( get_template_directory() . '/config/config-footer.php');
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
    Le thème semble utiliser include ou require : init.php
    Line 12: require_once( AWE_THUMBNAIL_INC_DIR . 'class-awe-thumbnail.php' );
    Si ces fonctions sont utilisées pour inclure des sections séparées d'un modèle à partir de fichiers indépendants, alors get_template_part () doit être utilisé à la place.
Autre thèmes vérifiés